aboutsummaryrefslogtreecommitdiff
path: root/security/nss
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-03-19 06:35:22 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-03-19 06:35:22 +0000
commit64768c1c1fe2170aeb750f0b83d0360914309268 (patch)
treec29e5a2eaf0916f9ec8135d17d3ecf1e53e2e86e /security/nss
parent357d90afb4569d6dbbb954e583a9b9c86f2b3982 (diff)
Link this library symbolically so that it can be linked into executables
along with OpenSSL. Without this, there is a symbol conflict with MD5_Update() which can cause applications such as Evolution 1.5 to crash when Kerberos support is enabled. The longer-term goal is to configure Mozilla's internal NSS to be linked symbolically which should allow us to enable OpenSSL support in gnomevfs2.
Notes
Notes: svn path=/head/; revision=104589
Diffstat (limited to 'security/nss')
-rw-r--r--security/nss/Makefile1
-rw-r--r--security/nss/files/patch-..::coreconf::FreeBSD.mk15
2 files changed, 10 insertions, 6 deletions
diff --git a/security/nss/Makefile b/security/nss/Makefile
index 60be38411d1e..b9e3e4fa86a4 100644
--- a/security/nss/Makefile
+++ b/security/nss/Makefile
@@ -7,6 +7,7 @@
PORTNAME= nss
PORTVERSION= 3.9
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR= security/nss/releases/NSS_${PORTVERSION:S/./_/g}_RTM/src
diff --git a/security/nss/files/patch-..::coreconf::FreeBSD.mk b/security/nss/files/patch-..::coreconf::FreeBSD.mk
index 215cc94a4a96..5c14081ba418 100644
--- a/security/nss/files/patch-..::coreconf::FreeBSD.mk
+++ b/security/nss/files/patch-..::coreconf::FreeBSD.mk
@@ -1,8 +1,5 @@
-
-$FreeBSD$
-
---- ../coreconf/FreeBSD.mk.orig Thu Mar 27 02:17:25 2003
-+++ ../coreconf/FreeBSD.mk Fri Apr 11 00:53:38 2003
+--- ../coreconf/FreeBSD.mk.orig Wed Mar 26 20:17:25 2003
++++ ../coreconf/FreeBSD.mk Fri Mar 19 01:23:30 2004
@@ -35,9 +35,9 @@
include $(CORE_DEPTH)/coreconf/UNIX.mk
@@ -34,7 +31,7 @@ $FreeBSD$
endif
ARCH = freebsd
-@@ -66,7 +68,7 @@
+@@ -66,12 +68,12 @@
MOZ_OBJFORMAT := $(shell test -x /usr/bin/objformat && /usr/bin/objformat || echo aout)
ifeq ($(MOZ_OBJFORMAT),elf)
@@ -43,3 +40,9 @@ $FreeBSD$
else
DLL_SUFFIX = so.1.0
endif
+
+-MKSHLIB = $(CC) $(DSO_LDOPTS)
++MKSHLIB = $(CC) -Wl,-Bsymbolic $(DSO_LDOPTS)
+ ifdef MAPFILE
+ # Add LD options to restrict exported symbols to those in the map file
+ endif