aboutsummaryrefslogtreecommitdiff
path: root/security/ocaml-cryptokit/Makefile
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2004-03-13 10:26:12 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2004-03-13 10:26:12 +0000
commit2c8ba2f7ff0a340b70e33f8b558429876e4ece13 (patch)
treec2946070fee2ac5b750a78a6c480f98ca244e312 /security/ocaml-cryptokit/Makefile
parent9dd4294568b02d67c05a8975d89455de7bd9561e (diff)
downloadports-2c8ba2f7ff0a340b70e33f8b558429876e4ece13.tar.gz
ports-2c8ba2f7ff0a340b70e33f8b558429876e4ece13.zip
Notes
Diffstat (limited to 'security/ocaml-cryptokit/Makefile')
-rw-r--r--security/ocaml-cryptokit/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/security/ocaml-cryptokit/Makefile b/security/ocaml-cryptokit/Makefile
index 6f98994ceb72..a1e3abe1ed4b 100644
--- a/security/ocaml-cryptokit/Makefile
+++ b/security/ocaml-cryptokit/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= cryptokit
-PORTVERSION= 1.1
+PORTVERSION= 1.2
CATEGORIES= security
MASTER_SITES= http://caml.inria.fr/distrib/bazar-ocaml/
PKGNAMEPREFIX= ocaml-
@@ -25,6 +25,8 @@ ALL_TARGET= all allopt
ALL_TARGET+= doc
.endif
+DOC_FILES= Changes LICENSE README
+
post-configure:
# CFLAGS,PREFIX safeness
@${REINPLACE_CMD} -E -e \
@@ -44,8 +46,11 @@ pre-install:
post-install:
.ifndef(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR}/doc
+ @${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}/doc
+.for file in ${DOC_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
.endif
.include <bsd.port.mk>