aboutsummaryrefslogtreecommitdiff
path: root/security/ocaml-cryptokit/Makefile
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2003-01-09 06:01:56 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2003-01-09 06:01:56 +0000
commit9853736c5417baa077c981296a8ee32ada261ced (patch)
treeb42ae8cbe1f1fc0706628a993150a64affebedbe /security/ocaml-cryptokit/Makefile
parentd6b114b48193e5a78c08cdffe904257dbed7fa6b (diff)
downloadports-9853736c5417baa077c981296a8ee32ada261ced.tar.gz
ports-9853736c5417baa077c981296a8ee32ada261ced.zip
Notes
Diffstat (limited to 'security/ocaml-cryptokit/Makefile')
-rw-r--r--security/ocaml-cryptokit/Makefile49
1 files changed, 49 insertions, 0 deletions
diff --git a/security/ocaml-cryptokit/Makefile b/security/ocaml-cryptokit/Makefile
new file mode 100644
index 000000000000..b9eb659db2b9
--- /dev/null
+++ b/security/ocaml-cryptokit/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: ocaml cryptokit
+# Date created: Thu Jan 9 03:04:06 BRST 2003
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cryptokit
+PORTVERSION= 1.1
+CATEGORIES= security
+MASTER_SITES= http://caml.inria.fr/distrib/bazar-ocaml/
+PKGNAMEPREFIX= ocaml-
+
+MAINTAINER= lioux@FreeBSD.org
+
+BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml
+
+USE_REINPLACE= yes
+
+ALL_TARGET= all allopt
+
+.ifndef(NOPORTDOCS)
+ALL_TARGET+= doc
+.endif
+
+post-configure:
+# CFLAGS,PREFIX safeness
+ @${REINPLACE_CMD} -E -e \
+ 's|^(INSTALLDIR).*$$|\1=${PREFIX}/lib/ocaml|; \
+ s|^CFLAGS=|CFLAGS\+=|; \
+ s|(^CFLAGS.*)-O|\1|' \
+ ${WRKSRC}/Makefile
+
+pre-install:
+# in pre-install to make sure we're using the correct user:group
+# combo
+ @${REINPLACE_CMD} -E -e \
+ 's|cp |${INSTALL_DATA} |' \
+ ${WRKSRC}/Makefile
+# create installation dir
+ @${MKDIR} ${PREFIX}/lib/ocaml
+
+post-install:
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>