aboutsummaryrefslogtreecommitdiff
path: root/security/ocaml-cryptokit
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2003-01-09 06:01:56 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2003-01-09 06:01:56 +0000
commit9853736c5417baa077c981296a8ee32ada261ced (patch)
treeb42ae8cbe1f1fc0706628a993150a64affebedbe /security/ocaml-cryptokit
parentd6b114b48193e5a78c08cdffe904257dbed7fa6b (diff)
downloadports-9853736c5417baa077c981296a8ee32ada261ced.tar.gz
ports-9853736c5417baa077c981296a8ee32ada261ced.zip
Notes
Diffstat (limited to 'security/ocaml-cryptokit')
-rw-r--r--security/ocaml-cryptokit/Makefile49
-rw-r--r--security/ocaml-cryptokit/distinfo1
-rw-r--r--security/ocaml-cryptokit/pkg-comment1
-rw-r--r--security/ocaml-cryptokit/pkg-descr21
-rw-r--r--security/ocaml-cryptokit/pkg-plist93
5 files changed, 165 insertions, 0 deletions
diff --git a/security/ocaml-cryptokit/Makefile b/security/ocaml-cryptokit/Makefile
new file mode 100644
index 000000000000..b9eb659db2b9
--- /dev/null
+++ b/security/ocaml-cryptokit/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: ocaml cryptokit
+# Date created: Thu Jan 9 03:04:06 BRST 2003
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cryptokit
+PORTVERSION= 1.1
+CATEGORIES= security
+MASTER_SITES= http://caml.inria.fr/distrib/bazar-ocaml/
+PKGNAMEPREFIX= ocaml-
+
+MAINTAINER= lioux@FreeBSD.org
+
+BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml
+
+USE_REINPLACE= yes
+
+ALL_TARGET= all allopt
+
+.ifndef(NOPORTDOCS)
+ALL_TARGET+= doc
+.endif
+
+post-configure:
+# CFLAGS,PREFIX safeness
+ @${REINPLACE_CMD} -E -e \
+ 's|^(INSTALLDIR).*$$|\1=${PREFIX}/lib/ocaml|; \
+ s|^CFLAGS=|CFLAGS\+=|; \
+ s|(^CFLAGS.*)-O|\1|' \
+ ${WRKSRC}/Makefile
+
+pre-install:
+# in pre-install to make sure we're using the correct user:group
+# combo
+ @${REINPLACE_CMD} -E -e \
+ 's|cp |${INSTALL_DATA} |' \
+ ${WRKSRC}/Makefile
+# create installation dir
+ @${MKDIR} ${PREFIX}/lib/ocaml
+
+post-install:
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/ocaml-cryptokit/distinfo b/security/ocaml-cryptokit/distinfo
new file mode 100644
index 000000000000..0f8a2b960d84
--- /dev/null
+++ b/security/ocaml-cryptokit/distinfo
@@ -0,0 +1 @@
+MD5 (cryptokit-1.1.tar.gz) = c4f22e4dd3d44eeab4f3bcdb25b95980
diff --git a/security/ocaml-cryptokit/pkg-comment b/security/ocaml-cryptokit/pkg-comment
new file mode 100644
index 000000000000..dacb6dcf4476
--- /dev/null
+++ b/security/ocaml-cryptokit/pkg-comment
@@ -0,0 +1 @@
+A variety of cryptographic primitives for Objective Caml
diff --git a/security/ocaml-cryptokit/pkg-descr b/security/ocaml-cryptokit/pkg-descr
new file mode 100644
index 000000000000..885559b971ca
--- /dev/null
+++ b/security/ocaml-cryptokit/pkg-descr
@@ -0,0 +1,21 @@
+[ excerpt from developer's www site ]
+
+The Cryptokit library for Objective Caml provides a variety of
+cryptographic primitives that can be used to implement cryptographic
+protocols in security-sensitive applications. The primitives provided
+include:
+
+Symmetric-key cryptography: AES, DES, Triple-DES, ARCfour, in ECB,
+CBC, CFB and OFB modes. Public-key cryptography: RSA encryption and
+signature; Diffie-Hellman key agreement. Hash functions and MACs:
+SHA-1, MD5, and MACs based on AES and DES. Random number generation.
+Encodings and compression: base 64, hexadecimal, Zlib compression.
+
+Additional ciphers and hashes can easily be used in conjunction
+with the library. In particular, basic mechanisms such as chaining
+modes, output buffering, and padding are provided by generic classes
+that can easily be composed with user-provided ciphers. More
+generally, the library promotes a "Lego"-like style of constructing
+and composing transformations over character streams.
+
+WWW: http://cristal.inria.fr/~xleroy/software.html
diff --git a/security/ocaml-cryptokit/pkg-plist b/security/ocaml-cryptokit/pkg-plist
new file mode 100644
index 000000000000..42842b220daa
--- /dev/null
+++ b/security/ocaml-cryptokit/pkg-plist
@@ -0,0 +1,93 @@
+lib/ocaml/cryptokit.cma
+lib/ocaml/cryptokit.cmi
+lib/ocaml/cryptokit.cmxa
+lib/ocaml/cryptokit.mli
+lib/ocaml/dllcryptokit.so
+lib/ocaml/libcryptokit.a
+%%PORTDOCS%%share/doc/cryptokit/Cryptokit.Base64.html
+%%PORTDOCS%%share/doc/cryptokit/Cryptokit.Block.aes_decrypt.html
+%%PORTDOCS%%share/doc/cryptokit/Cryptokit.Block.aes_encrypt.html
+%%PORTDOCS%%share/doc/cryptokit/Cryptokit.Block.block_cipher.html
+%%PORTDOCS%%share/doc/cryptokit/Cryptokit.Block.cbc_decrypt.html
+%%PORTDOCS%%share/doc/cryptokit/Cryptokit.Block.cbc_encrypt.html
+%%PORTDOCS%%share/doc/cryptokit/Cryptokit.Block.cfb_decrypt.html
+%%PORTDOCS%%share/doc/cryptokit/Cryptokit.Block.cfb_encrypt.html
+%%PORTDOCS%%share/doc/cryptokit/Cryptokit.Block.cipher.html
+%%PORTDOCS%%share/doc/cryptokit/Cryptokit.Block.cipher_padded_decrypt.html
+%%PORTDOCS%%share/doc/cryptokit/Cryptokit.Block.cipher_padded_encrypt.html
+%%PORTDOCS%%share/doc/cryptokit/Cryptokit.Block.des_decrypt.html
+%%PORTDOCS%%share/doc/cryptokit/Cryptokit.Block.des_encrypt.html
+%%PORTDOCS%%share/doc/cryptokit/Cryptokit.Block.html
+%%PORTDOCS%%share/doc/cryptokit/Cryptokit.Block.mac.html
+%%PORTDOCS%%share/doc/cryptokit/Cryptokit.Block.mac_final_triple.html
+%%PORTDOCS%%share/doc/cryptokit/Cryptokit.Block.ofb.html
+%%PORTDOCS%%share/doc/cryptokit/Cryptokit.Block.triple_des_decrypt.html
+%%PORTDOCS%%share/doc/cryptokit/Cryptokit.Block.triple_des_encrypt.html
+%%PORTDOCS%%share/doc/cryptokit/Cryptokit.Cipher.html
+%%PORTDOCS%%share/doc/cryptokit/Cryptokit.DH.html
+%%PORTDOCS%%share/doc/cryptokit/Cryptokit.Hash.html
+%%PORTDOCS%%share/doc/cryptokit/Cryptokit.Hexa.html
+%%PORTDOCS%%share/doc/cryptokit/Cryptokit.MAC.html
+%%PORTDOCS%%share/doc/cryptokit/Cryptokit.Padding.html
+%%PORTDOCS%%share/doc/cryptokit/Cryptokit.Padding.scheme.html
+%%PORTDOCS%%share/doc/cryptokit/Cryptokit.RSA.html
+%%PORTDOCS%%share/doc/cryptokit/Cryptokit.Random.html
+%%PORTDOCS%%share/doc/cryptokit/Cryptokit.Random.rng.html
+%%PORTDOCS%%share/doc/cryptokit/Cryptokit.Stream.arcfour.html
+%%PORTDOCS%%share/doc/cryptokit/Cryptokit.Stream.cipher.html
+%%PORTDOCS%%share/doc/cryptokit/Cryptokit.Stream.html
+%%PORTDOCS%%share/doc/cryptokit/Cryptokit.Stream.stream_cipher.html
+%%PORTDOCS%%share/doc/cryptokit/Cryptokit.Zlib.html
+%%PORTDOCS%%share/doc/cryptokit/Cryptokit.hash.html
+%%PORTDOCS%%share/doc/cryptokit/Cryptokit.html
+%%PORTDOCS%%share/doc/cryptokit/Cryptokit.transform.html
+%%PORTDOCS%%share/doc/cryptokit/index.html
+%%PORTDOCS%%share/doc/cryptokit/index_attributes.html
+%%PORTDOCS%%share/doc/cryptokit/index_class_types.html
+%%PORTDOCS%%share/doc/cryptokit/index_classes.html
+%%PORTDOCS%%share/doc/cryptokit/index_exceptions.html
+%%PORTDOCS%%share/doc/cryptokit/index_methods.html
+%%PORTDOCS%%share/doc/cryptokit/index_module_types.html
+%%PORTDOCS%%share/doc/cryptokit/index_modules.html
+%%PORTDOCS%%share/doc/cryptokit/index_types.html
+%%PORTDOCS%%share/doc/cryptokit/index_values.html
+%%PORTDOCS%%share/doc/cryptokit/style.css
+%%PORTDOCS%%share/doc/cryptokit/type_Cryptokit.Base64.html
+%%PORTDOCS%%share/doc/cryptokit/type_Cryptokit.Block.aes_decrypt.html
+%%PORTDOCS%%share/doc/cryptokit/type_Cryptokit.Block.aes_encrypt.html
+%%PORTDOCS%%share/doc/cryptokit/type_Cryptokit.Block.block_cipher.html
+%%PORTDOCS%%share/doc/cryptokit/type_Cryptokit.Block.cbc_decrypt.html
+%%PORTDOCS%%share/doc/cryptokit/type_Cryptokit.Block.cbc_encrypt.html
+%%PORTDOCS%%share/doc/cryptokit/type_Cryptokit.Block.cfb_decrypt.html
+%%PORTDOCS%%share/doc/cryptokit/type_Cryptokit.Block.cfb_encrypt.html
+%%PORTDOCS%%share/doc/cryptokit/type_Cryptokit.Block.cipher.html
+%%PORTDOCS%%share/doc/cryptokit/type_Cryptokit.Block.cipher_padded_decrypt.html
+%%PORTDOCS%%share/doc/cryptokit/type_Cryptokit.Block.cipher_padded_encrypt.html
+%%PORTDOCS%%share/doc/cryptokit/type_Cryptokit.Block.des_decrypt.html
+%%PORTDOCS%%share/doc/cryptokit/type_Cryptokit.Block.des_encrypt.html
+%%PORTDOCS%%share/doc/cryptokit/type_Cryptokit.Block.html
+%%PORTDOCS%%share/doc/cryptokit/type_Cryptokit.Block.mac.html
+%%PORTDOCS%%share/doc/cryptokit/type_Cryptokit.Block.mac_final_triple.html
+%%PORTDOCS%%share/doc/cryptokit/type_Cryptokit.Block.ofb.html
+%%PORTDOCS%%share/doc/cryptokit/type_Cryptokit.Block.triple_des_decrypt.html
+%%PORTDOCS%%share/doc/cryptokit/type_Cryptokit.Block.triple_des_encrypt.html
+%%PORTDOCS%%share/doc/cryptokit/type_Cryptokit.Cipher.html
+%%PORTDOCS%%share/doc/cryptokit/type_Cryptokit.DH.html
+%%PORTDOCS%%share/doc/cryptokit/type_Cryptokit.Hash.html
+%%PORTDOCS%%share/doc/cryptokit/type_Cryptokit.Hexa.html
+%%PORTDOCS%%share/doc/cryptokit/type_Cryptokit.MAC.html
+%%PORTDOCS%%share/doc/cryptokit/type_Cryptokit.Padding.html
+%%PORTDOCS%%share/doc/cryptokit/type_Cryptokit.Padding.scheme.html
+%%PORTDOCS%%share/doc/cryptokit/type_Cryptokit.RSA.html
+%%PORTDOCS%%share/doc/cryptokit/type_Cryptokit.Random.html
+%%PORTDOCS%%share/doc/cryptokit/type_Cryptokit.Random.rng.html
+%%PORTDOCS%%share/doc/cryptokit/type_Cryptokit.Stream.arcfour.html
+%%PORTDOCS%%share/doc/cryptokit/type_Cryptokit.Stream.cipher.html
+%%PORTDOCS%%share/doc/cryptokit/type_Cryptokit.Stream.html
+%%PORTDOCS%%share/doc/cryptokit/type_Cryptokit.Stream.stream_cipher.html
+%%PORTDOCS%%share/doc/cryptokit/type_Cryptokit.Zlib.html
+%%PORTDOCS%%share/doc/cryptokit/type_Cryptokit.hash.html
+%%PORTDOCS%%share/doc/cryptokit/type_Cryptokit.html
+%%PORTDOCS%%share/doc/cryptokit/type_Cryptokit.transform.html
+%%PORTDOCS%%@dirrm share/doc/cryptokit
+@unexec rmdir %D/lib/ocaml 2>/dev/null || true