aboutsummaryrefslogtreecommitdiff
path: root/security/ocaml-ssl/Makefile
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-03-26 21:32:39 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-03-26 21:32:39 +0000
commitb0f417a9b53bc700b6cd01158a16510da4951956 (patch)
treea74da1bcdc1e80d7f43fde202c2accbcf6ff64c8 /security/ocaml-ssl/Makefile
parent26a172d5164f050502f18fdbe29e5b5d6fdd69a3 (diff)
downloadports-b0f417a9b53bc700b6cd01158a16510da4951956.tar.gz
ports-b0f417a9b53bc700b6cd01158a16510da4951956.zip
Notes
Diffstat (limited to 'security/ocaml-ssl/Makefile')
-rw-r--r--security/ocaml-ssl/Makefile27
1 files changed, 7 insertions, 20 deletions
diff --git a/security/ocaml-ssl/Makefile b/security/ocaml-ssl/Makefile
index 19c6fde5258c..d6743d24c73a 100644
--- a/security/ocaml-ssl/Makefile
+++ b/security/ocaml-ssl/Makefile
@@ -11,10 +11,10 @@ DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
MAINTAINER= jaapb@kerguelen.org
COMMENT= OpenSSL bindings for OCaml
-DOCSDIR= ${PREFIX}/share/doc/ocaml/${PORTNAME}
-USE_GMAKE= yes
+USES= gmake
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --docdir=${DOCSDIR}
+MAKE_ENV= OCAMLFIND_INSTFLAGS="-ldconf ignore"
MAKE_JOBS_UNSAFE= yes
USE_OPENSSL= yes
@@ -25,26 +25,13 @@ USE_OCAMLFIND_PLIST= yes
ALL_TARGET= all doc
-.if !defined(NOPORTDOCS)
+DOCSDIR= ${OCAML_DOCSDIR}/${PORTNAME}
PORTDOCS= *
-.endif
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
-post-extract:
-# For nonstandard prefixes
-.if !exists(${OCAMLFIND_DESTDIR})
- ${MKDIR} ${OCAMLFIND_DESTDIR}
-.endif
-.if !exists(${OCAMLFIND_LDCONF})
- ${TOUCH} ${OCAMLFIND_LDCONF}
-.endif
+OPTIONS_DEFINE= DOCS
post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}/html
- ${INSTALL_MAN} ${WRKSRC}/doc/html/* ${DOCSDIR}/html
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}/html
+ ${INSTALL_DATA} ${WRKSRC}/doc/html/* ${STAGEDIR}${DOCSDIR}/html
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>