aboutsummaryrefslogtreecommitdiff
path: root/security/oidentd/Makefile
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2004-10-15 17:44:18 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2004-10-15 17:44:18 +0000
commitaac49f07a4c681ce0ad18505efa27395244662b9 (patch)
tree50a58cbecfc19160c4d6aef2c57ee28c8ff13871 /security/oidentd/Makefile
parent3ed0900d70d3d04fdd796154f64aec44b08a6976 (diff)
downloadports-aac49f07a4c681ce0ad18505efa27395244662b9.tar.gz
ports-aac49f07a4c681ce0ad18505efa27395244662b9.zip
Notes
Diffstat (limited to 'security/oidentd/Makefile')
-rw-r--r--security/oidentd/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/security/oidentd/Makefile b/security/oidentd/Makefile
index 95284cb23008..144d0c3eab4a 100644
--- a/security/oidentd/Makefile
+++ b/security/oidentd/Makefile
@@ -7,7 +7,7 @@
PORTNAME= oidentd
PORTVERSION= 2.0.7
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ojnk
@@ -15,7 +15,7 @@ MASTER_SITE_SUBDIR= ojnk
MAINTAINER= oliver@FreeBSD.org
COMMENT= Ident server that supports user-defined ident strings
-USE_GMAKE= yes
+USE_RC_SUBR= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
@@ -25,10 +25,6 @@ MAN8= oidentd.8
PLIST_FILES= sbin/oidentd etc/rc.d/oidentd.sh etc/oidentd.conf.sample \
etc/oidentd_masq.conf.sample
-.include <bsd.port.pre.mk>
-
-USE_RC_SUBR= yes
-
post-patch:
@${REINPLACE_CMD} -e 's,/etc/,${PREFIX}&,g' ${WRKSRC}/src/oidentd.h
@@ -41,7 +37,12 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/oidentd ${PREFIX}/sbin
${INSTALL_DATA} ${MAN5:S,^,${FILESDIR}/,:S,5$,sample,} ${PREFIX}/etc
${INSTALL_SCRIPT} ${WRKDIR}/oidentd.sh ${PREFIX}/etc/rc.d
+.if !defined(NO_INSTALL_MANPAGES)
+.for MANFILE in ${MAN5} ${MAN8}
+ @${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},g' ${WRKSRC}/doc/${MANFILE}
+.endfor
${INSTALL_MAN} ${MAN5:S,^,${WRKSRC}/doc/,} ${PREFIX}/man/man5
${INSTALL_MAN} ${MAN8:S,^,${WRKSRC}/doc/,} ${PREFIX}/man/man8
+.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>