aboutsummaryrefslogtreecommitdiff
path: root/security/oidentd
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2008-03-25 16:43:13 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2008-03-25 16:43:13 +0000
commitb096773969857b0ea04a10786acc26b039688873 (patch)
tree4d20fe78aeafe8398fe14f611cc41570fb889a9c /security/oidentd
parent91a33e79ae54ce923376dbece4967f367937c067 (diff)
downloadports-b096773969857b0ea04a10786acc26b039688873.tar.gz
ports-b096773969857b0ea04a10786acc26b039688873.zip
Notes
Diffstat (limited to 'security/oidentd')
-rw-r--r--security/oidentd/Makefile28
-rw-r--r--security/oidentd/files/oidentd.in (renamed from security/oidentd/files/oidentd.sh)0
2 files changed, 19 insertions, 9 deletions
diff --git a/security/oidentd/Makefile b/security/oidentd/Makefile
index 62ce4f2e5944..4b4a3b2aa442 100644
--- a/security/oidentd/Makefile
+++ b/security/oidentd/Makefile
@@ -7,6 +7,7 @@
PORTNAME= oidentd
PORTVERSION= 2.0.8
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ojnk
@@ -14,27 +15,36 @@ MASTER_SITE_SUBDIR= ojnk
MAINTAINER= oliver@FreeBSD.org
COMMENT= Ident server that supports user-defined ident strings
-USE_RC_SUBR= yes
+USE_RC_SUBR= oidentd
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAN5= oidentd.conf.5 oidentd_masq.conf.5
MAN8= oidentd.8
-PLIST_FILES= sbin/oidentd etc/rc.d/oidentd.sh etc/oidentd.conf.sample \
+PLIST_FILES= sbin/oidentd etc/oidentd.conf.sample \
etc/oidentd_masq.conf.sample
+OPTIONS= IPV6 "Enable IPv6 support" on \
+ MASQ "Enable NAT/IP masq support" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITHOUT_IPV6)
+CONFIGURE_ARGS+=--disable-ipv6
+.else
+CATEGORIES+= ipv6
+.endif
+
+.if defined(WITHOUT_MASQ)
+CONFIGURE_ARGS+=--disable-masq
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's,/etc/,${PREFIX}&,g' ${WRKSRC}/src/oidentd.h
-post-build:
- @${SED} -e 's,%%PREFIX%%,${PREFIX},g' \
- -e 's,%%RC_SUBR%%,${RC_SUBR},g' \
- <${FILESDIR}/oidentd.sh >${WRKDIR}/oidentd.sh
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/oidentd ${PREFIX}/sbin
${INSTALL_DATA} ${MAN5:S,^,${FILESDIR}/,:S,5$,sample,} ${PREFIX}/etc
- ${INSTALL_SCRIPT} ${WRKDIR}/oidentd.sh ${PREFIX}/etc/rc.d
.if !defined(NO_INSTALL_MANPAGES)
.for MANFILE in ${MAN5} ${MAN8}
@${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},g' ${WRKSRC}/doc/${MANFILE}
@@ -43,4 +53,4 @@ do-install:
${INSTALL_MAN} ${MAN8:S,^,${WRKSRC}/doc/,} ${PREFIX}/man/man8
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/security/oidentd/files/oidentd.sh b/security/oidentd/files/oidentd.in
index 493fea51fb31..493fea51fb31 100644
--- a/security/oidentd/files/oidentd.sh
+++ b/security/oidentd/files/oidentd.in