aboutsummaryrefslogtreecommitdiff
path: root/security/oidentd
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2004-01-31 13:32:34 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2004-01-31 13:32:34 +0000
commit8d52fc872700ccd87967dad0e1871538093677d0 (patch)
treefd0aa99c261baef5d6600425a35636066ac185e9 /security/oidentd
parentf78a9532e31e1bc8344b64870631659dd809568d (diff)
downloadports-8d52fc872700ccd87967dad0e1871538093677d0.tar.gz
ports-8d52fc872700ccd87967dad0e1871538093677d0.zip
Notes
Diffstat (limited to 'security/oidentd')
-rw-r--r--security/oidentd/Makefile25
-rw-r--r--security/oidentd/files/oidentd.conf.sample24
-rw-r--r--security/oidentd/files/oidentd.sh32
-rw-r--r--security/oidentd/files/oidentd_masq.conf.sample2
-rw-r--r--security/oidentd/pkg-plist3
5 files changed, 85 insertions, 1 deletions
diff --git a/security/oidentd/Makefile b/security/oidentd/Makefile
index 341e2aaf10fe..4774427f465d 100644
--- a/security/oidentd/Makefile
+++ b/security/oidentd/Makefile
@@ -7,6 +7,7 @@
PORTNAME= oidentd
PORTVERSION= 2.0.7
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ojnk
@@ -16,7 +17,29 @@ COMMENT= Ident server that supports user-defined ident strings
USE_GMAKE= yes
GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
MAN5= oidentd.conf.5 oidentd_masq.conf.5
MAN8= oidentd.8
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500038
+RC_SUBR= /etc/rc.subr
+.else
+USE_RC_SUBR= yes
+.endif
+
+post-build:
+ @${SED} -e 's,%%PREFIX%%,${PREFIX},g' \
+ -e 's,%%RC_SUBR%%,${RC_SUBR},g' \
+ <${FILESDIR}/oidentd.sh >${WRKDIR}/oidentd.sh
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/oidentd ${PREFIX}/sbin
+ ${INSTALL_DATA} ${MAN5:S,^,${FILESDIR}/,:S,5$,sample,} ${PREFIX}/etc
+ ${INSTALL_SCRIPT} ${WRKDIR}/oidentd.sh ${PREFIX}/etc/rc.d
+ ${INSTALL_MAN} ${MAN5:S,^,${WRKSRC}/doc/,} ${PREFIX}/man/man5
+ ${INSTALL_MAN} ${MAN8:S,^,${WRKSRC}/doc/,} ${PREFIX}/man/man8
+
+.include <bsd.port.post.mk>
diff --git a/security/oidentd/files/oidentd.conf.sample b/security/oidentd/files/oidentd.conf.sample
new file mode 100644
index 000000000000..9cbd9cbb06af
--- /dev/null
+++ b/security/oidentd/files/oidentd.conf.sample
@@ -0,0 +1,24 @@
+default {
+ default {
+ allow spoof
+ deny spoof_all
+ deny spoof_privport
+ allow random_numeric
+ allow numeric
+ allow hide
+ }
+}
+
+user root {
+ default {
+ force reply "UNKNOWN"
+ }
+}
+
+#user eggdrop {
+# default {
+# allow spoof
+# allow spoof_all
+# allow spoof_privport
+# }
+#}
diff --git a/security/oidentd/files/oidentd.sh b/security/oidentd/files/oidentd.sh
new file mode 100644
index 000000000000..72bf842f09c0
--- /dev/null
+++ b/security/oidentd/files/oidentd.sh
@@ -0,0 +1,32 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: oidentd
+# REQUIRE: DAEMON
+# KEYWORD: FreeBSD shutdown
+
+#
+# Add the following lines to /etc/rc.conf to enable dovecot:
+#
+#oidentd_enable="YES"
+#
+# See oidentd(8) for flags.
+#
+
+. %%RC_SUBR%%
+
+name=oidentd
+rcvar=`set_rcvar`
+
+command=%%PREFIX%%/sbin/${name}
+required_files=%%PREFIX%%/etc/${name}.conf
+
+# set defaults
+
+oidentd_enable=${oidentd_enable:-"NO"}
+oidentd_flags=${oidentd_flags:-""}
+
+load_rc_config ${name}
+run_rc_command "$1"
diff --git a/security/oidentd/files/oidentd_masq.conf.sample b/security/oidentd/files/oidentd_masq.conf.sample
new file mode 100644
index 000000000000..9b7ae2d15185
--- /dev/null
+++ b/security/oidentd/files/oidentd_masq.conf.sample
@@ -0,0 +1,2 @@
+192.168.1.1/32 client1 UNIX
+192.168.2.1/32 client2 UNIX
diff --git a/security/oidentd/pkg-plist b/security/oidentd/pkg-plist
index 193ec3715ac2..8fef1bf981d3 100644
--- a/security/oidentd/pkg-plist
+++ b/security/oidentd/pkg-plist
@@ -1 +1,4 @@
sbin/oidentd
+etc/oidentd.conf.sample
+etc/oidentd_masq.conf.sample
+etc/rc.d/oidentd.sh