aboutsummaryrefslogtreecommitdiff
path: root/security/oinkmaster/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-06-26 18:47:37 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-06-26 18:47:37 +0000
commit92000dedbc04f895cda502281c46d8cd4bcc9328 (patch)
tree92350eb479f6144b6ac25fb5358f167babd6e3f0 /security/oinkmaster/Makefile
parent5ad18c923437b814be4eea81e9e6744a1f8665a4 (diff)
downloadports-92000dedbc04f895cda502281c46d8cd4bcc9328.tar.gz
ports-92000dedbc04f895cda502281c46d8cd4bcc9328.zip
Notes
Diffstat (limited to 'security/oinkmaster/Makefile')
-rw-r--r--security/oinkmaster/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/security/oinkmaster/Makefile b/security/oinkmaster/Makefile
index 3a81439d4514..e9547ad18b1a 100644
--- a/security/oinkmaster/Makefile
+++ b/security/oinkmaster/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= oinkmaster
-PORTVERSION= 0.7
-PORTREVISION= 1
+PORTVERSION= 1.0
CATEGORIES= security
MASTER_SITES= ftp://ftp.it.su.se/pub/users/andreas/oinkmaster/
@@ -21,9 +20,14 @@ USE_REINPLACE= yes
NO_BUILD= yes
USE_PERL5_RUN= yes
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= needs at least perl 5.6.1
+.endif
+
post-patch:
- @${REINPLACE_CMD} -e 's,/usr/bin/perl,${PERL},g;\
- s,\./oinkmaster.conf,${PREFIX}/etc/oinkmaster.conf,g' \
+ @${REINPLACE_CMD} -e 's,/usr/bin/perl,${PERL},g' \
${WRKSRC}/oinkmaster.pl
do-install:
@@ -34,4 +38,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>