aboutsummaryrefslogtreecommitdiff
path: root/security/openbsm-devel
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2013-02-19 02:20:27 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2013-02-19 02:20:27 +0000
commit77241d88d02180794c3b56347c8a5ed0471493ae (patch)
treeb37bb7abdf2bd297be8c776cee896129f0dcda02 /security/openbsm-devel
parent41a95c5e377a0b91ffd99ae580fc157d815b3f3b (diff)
downloadports-77241d88d02180794c3b56347c8a5ed0471493ae.tar.gz
ports-77241d88d02180794c3b56347c8a5ed0471493ae.zip
Notes
Diffstat (limited to 'security/openbsm-devel')
-rw-r--r--security/openbsm-devel/Makefile1
-rw-r--r--security/openbsm-devel/files/patch-libbsm__bsm_io.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/security/openbsm-devel/Makefile b/security/openbsm-devel/Makefile
index a2502c7addb9..8b30648c19ff 100644
--- a/security/openbsm-devel/Makefile
+++ b/security/openbsm-devel/Makefile
@@ -3,6 +3,7 @@
PORTNAME= openbsm
DISTVERSION= 1.2-alpha3
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://www.trustedbsd.org/downloads/ \
http://mirrors.rit.edu/zi/
diff --git a/security/openbsm-devel/files/patch-libbsm__bsm_io.c b/security/openbsm-devel/files/patch-libbsm__bsm_io.c
new file mode 100644
index 000000000000..89ea4bca4424
--- /dev/null
+++ b/security/openbsm-devel/files/patch-libbsm__bsm_io.c
@@ -0,0 +1,11 @@
+--- ./libbsm/bsm_io.c.orig 2013-02-18 21:07:28.000000000 -0500
++++ ./libbsm/bsm_io.c 2013-02-18 21:07:38.000000000 -0500
+@@ -949,7 +949,7 @@
+ {
+
+ print_tok_type(fp, tok->id, "header", oflags);
+- if (oflags & AU_OFLAG_RAW) {
++ if (oflags & AU_OFLAG_XML) {
+ open_attr(fp, "version");
+ print_1_byte(fp, tok->tt.hdr32.version, "%u");
+ close_attr(fp);