aboutsummaryrefslogtreecommitdiff
path: root/security/opencdk/Makefile
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2003-01-24 23:13:30 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2003-01-24 23:13:30 +0000
commit255324346134c16363715c5b922f2f0d4fe9047d (patch)
tree427f865533add37b6d56fa83a6cab67a13fb31e7 /security/opencdk/Makefile
parent3b12786f798582fc0415c88a01aeaf76bfb5855d (diff)
Notes
Diffstat (limited to 'security/opencdk/Makefile')
-rw-r--r--security/opencdk/Makefile17
1 files changed, 10 insertions, 7 deletions
diff --git a/security/opencdk/Makefile b/security/opencdk/Makefile
index 25def0547c6b..071574da24c8 100644
--- a/security/opencdk/Makefile
+++ b/security/opencdk/Makefile
@@ -9,24 +9,27 @@ PORTNAME= opencdk
PORTVERSION= 0.4.1
CATEGORIES= security
MASTER_SITES= http://gd.tuwien.ac.at/privacy/gnupg/alpha/gnutls/opencdk/ \
- ftp://ftp.gnutls.org/pub/gnutls/opencdk/ \
- ftp://ftp.gnupg.org/pub/gcrypt/alpha/gnutls/opencdk/ \
http://www.mirrors.wiretapped.net/security/network-security/gnutls/opencdk/ \
- ftp://ftp.mirrors.wiretapped.net/security/network-security/gnutls/opencdk/
+ ftp://ftp.gnupg.org/pub/gcrypt/alpha/gnutls/opencdk/ \
+ ftp://ftp.mirrors.wiretapped.net/security/network-security/gnutls/opencdk/ \
+ ftp://ftp.gnutls.org/pub/gnutls/opencdk/
MAINTAINER= sergei@kolobov.com
-LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt \
- gcrypt.6:${PORTSDIR}/security/libgcrypt
+LIB_DEPENDS= gcrypt.6:${PORTSDIR}/security/libgcrypt
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib -lgnugetopt"
+CONFIGURE_ARGS= --with-libgcrypt-prefix=${LOCALBASE}
+USE_REINPLACE= yes
DOCS= AUTHORS NEWS README THANKS
+post-patch:
+ ${REINPLACE_CMD} -e 's,#include <malloc.h>,#include<stdlib.h>,' \
+ ${WRKSRC}/src/encrypt.c ${WRKSRC}/src/main.c
+
post-install:
@${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/tests/*.c ${EXAMPLESDIR}