aboutsummaryrefslogtreecommitdiff
path: root/security/openct/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-07-06 14:35:12 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-07-06 14:35:12 +0000
commit7ea7c22500d2e1c94f27b75ffee00e80dfa7e838 (patch)
tree2c170ca22682b5353aea60df5fb264672ca13ba4 /security/openct/Makefile
parentce88553f7c98e7c3888c0ea2dd6b7cf18e63ea65 (diff)
Notes
Diffstat (limited to 'security/openct/Makefile')
-rw-r--r--security/openct/Makefile51
1 files changed, 51 insertions, 0 deletions
diff --git a/security/openct/Makefile b/security/openct/Makefile
new file mode 100644
index 000000000000..454c38c3db1e
--- /dev/null
+++ b/security/openct/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: openct
+# Date created: 2004-09-08
+# Whom: Janos Mohacsi <janos.mohacsi@bsd.hu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= openct
+PORTVERSION= 0.6.5
+CATEGORIES= security
+MASTER_SITES= http://www.opensc.org/files/
+
+MAINTAINER= janos.mohacsi@bsd.hu
+COMMENT= A middleware framework for smart card terminals
+
+USE_LIBTOOL_VER= 15
+USE_GMAKE= yes
+USE_GNOME= pkgconfig
+INSTALLS_SHLIB= yes
+
+CONFIGURE_ARGS= --prefix=${PREFIX}
+
+MAN1= openct-tool.1
+
+DOC_FILES= README export-wiki.sh export-wiki.xsl ${HTML_FILES}
+
+HTML_FILES= AuthorsAndCredits.html FilesTools.html LicenseText.html \
+ OperatingSystems.html QuickStart.html RecentResults.html \
+ RemoteAccess.html SecureSetup.html SupportedReaders.html \
+ TroubleShooting.html cardman.html ccid.html egate.html \
+ etoken.html eutron.html gempc.html ikey2032.html \
+ ikey3000.html index.html kaan.html smartboard.html \
+ towitoko.html trac.css
+
+.if !defined(WITHOUT_PCSC_LITE)
+LIB_DEPENDS+= pcsclite.1:${PORTSDIR}/devel/pcsc-lite
+.endif
+
+post-install:
+ #run files
+ ${MKDIR} /var/run/${PORTNAME}
+ #sample config file
+ ${INSTALL_DATA} ${WRKSRC}/etc/openct.conf ${PREFIX}/etc/openct.conf-sample
+ #start daemons script
+ ${INSTALL_SCRIPT} ${WRKSRC}/etc/init-script ${PREFIX}/etc/rc.d/openct.sh
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC}/doc && ${INSTALL_DATA} ${DOC_FILES} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>