aboutsummaryrefslogtreecommitdiff
path: root/security/openct
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2008-08-26 13:33:25 +0000
committerAlex Dupre <ale@FreeBSD.org>2008-08-26 13:33:25 +0000
commitbd9f73b777fc0953a364764cef35a931cec65783 (patch)
treec66b12435df336309df4a84e297bbca422a4d5be /security/openct
parent9ab35a0cac2f720cf1e25243af1da325062ad556 (diff)
downloadports-bd9f73b777fc0953a364764cef35a931cec65783.tar.gz
ports-bd9f73b777fc0953a364764cef35a931cec65783.zip
Notes
Diffstat (limited to 'security/openct')
-rw-r--r--security/openct/Makefile30
-rw-r--r--security/openct/distinfo6
-rw-r--r--security/openct/files/patch-etc_Makefile.in15
-rw-r--r--security/openct/files/patch-etc_openct.conf.in9
4 files changed, 37 insertions, 23 deletions
diff --git a/security/openct/Makefile b/security/openct/Makefile
index 31d7b2ac5d1a..53401ff63da9 100644
--- a/security/openct/Makefile
+++ b/security/openct/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= openct
-DISTVERSION= 0.6.14
+PORTVERSION= 0.6.15
CATEGORIES= security
MASTER_SITES= http://www.opensc-project.org/files/${PORTNAME}/ \
http://www.opensc-project.org/files/${PORTNAME}/testing/
@@ -14,46 +14,48 @@ MASTER_SITES= http://www.opensc-project.org/files/${PORTNAME}/ \
MAINTAINER= ale@FreeBSD.org
COMMENT= A middleware framework for smart card terminals
-OPTIONS= USB "Install libusb for USB tokens/readers support" on \
- PCSC "Install pcsc-lite to build the PC/SC->OpenCT frontend" off
+OPTIONS= PCSC "Enable PC/SC support" off
USE_AUTOTOOLS= libltdl:15
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack pkgconfig
+USE_GNOME= pkgconfig
USE_LDCONFIG= yes
USE_RC_SUBR= openct
SUB_FILES= etoken.conf
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV= LTLIB_CFLAGS="-I${LOCALBASE}/include" \
+ LTLIB_LIBS="-L${LOCALBASE}/lib -lltdl"
+
+CONFIGURE_ARGS= --with-ifddir=${PREFIX}/lib/ifd \
+ --localstatedir=/var
MAN1= openct-tool.1
-DOC_FILES= README export-wiki.sh export-wiki.xsl trac.css *.html api
+DOC_FILES= trac.css *.html
PORTDOCS= *
.include <bsd.port.pre.mk>
-.if !defined(WITHOUT_USB) || exists(${LOCALBASE}/lib/libusb-0.1.so)
-LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
-.endif
-
-.if defined(WITH_PCSC) || exists(${LOCALBASE}/lib/libpcsclite.so)
+.if defined(WITH_PCSC)
LIB_DEPENDS+= pcsclite.1:${PORTSDIR}/devel/pcsc-lite
+CONFIGURE_ARGS+=--enable-pcsc
PLIST_SUB+= PCSC=""
.else
PLIST_SUB+= PCSC="@comment "
.endif
+post-patch:
+ @${REINPLACE_CMD} 's|(libdir)/pkgconfig|(prefix)/libdata/pkgconfig|' \
+ ${WRKSRC}/configure
+
post-install:
- ${INSTALL_DATA} ${WRKSRC}/etc/openct.conf ${PREFIX}/etc/openct.conf-sample
@${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKDIR}/etoken.conf ${EXAMPLESDIR}
.ifndef(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- @(cd ${WRKSRC}/doc && ${CP} -R ${DOC_FILES} ${DOCSDIR})
+ @(cd ${WRKSRC}/doc/nonpersistent/wiki.out/ && ${CP} -R ${DOC_FILES} ${DOCSDIR})
.endif
@${CAT} ${PKGMESSAGE}
diff --git a/security/openct/distinfo b/security/openct/distinfo
index daa7a8c8c37c..e67bdde16ea4 100644
--- a/security/openct/distinfo
+++ b/security/openct/distinfo
@@ -1,3 +1,3 @@
-MD5 (openct-0.6.14.tar.gz) = 04a5c0c7dedcb1ca0d550b1970fbf3b7
-SHA256 (openct-0.6.14.tar.gz) = 3df187f63eb6694652098238bdf967b304dad8f62e9219be4cf3b6d5ec5db58b
-SIZE (openct-0.6.14.tar.gz) = 670510
+MD5 (openct-0.6.15.tar.gz) = 70205beac03974e266fc259b6c9feaa8
+SHA256 (openct-0.6.15.tar.gz) = 737cafaef803e21d63c61a196b07b61c1ba47320a24b9c7c2790c68f92719b6a
+SIZE (openct-0.6.15.tar.gz) = 673265
diff --git a/security/openct/files/patch-etc_Makefile.in b/security/openct/files/patch-etc_Makefile.in
new file mode 100644
index 000000000000..36961455cb4a
--- /dev/null
+++ b/security/openct/files/patch-etc_Makefile.in
@@ -0,0 +1,15 @@
+--- etc/Makefile.in.orig 2008-08-26 15:00:26.000000000 +0200
++++ etc/Makefile.in 2008-08-26 15:00:52.000000000 +0200
+@@ -459,11 +459,7 @@
+ uninstall-nodist_udevSCRIPTS uninstall-sysconfDATA
+
+ install-exec-hook: install-sysconfDATA openct.conf
+- if [ -f "$(DESTDIR)$(sysconfdir)/openct.conf" ]; then \
+- $(INSTALL_DATA) openct.conf "$(DESTDIR)$(sysconfdir)/openct.conf.new"; \
+- else \
+- $(INSTALL_DATA) openct.conf "$(DESTDIR)$(sysconfdir)/openct.conf"; \
+- fi
++ $(INSTALL_DATA) openct.conf "$(DESTDIR)$(sysconfdir)/openct.conf-sample"; \
+
+ .in:
+ sed \
diff --git a/security/openct/files/patch-etc_openct.conf.in b/security/openct/files/patch-etc_openct.conf.in
index 414c876363cc..30a06e1047da 100644
--- a/security/openct/files/patch-etc_openct.conf.in
+++ b/security/openct/files/patch-etc_openct.conf.in
@@ -1,14 +1,11 @@
-
-$FreeBSD$
-
---- etc/openct.conf.in.orig
-+++ etc/openct.conf.in
+--- etc/openct.conf.in.orig 2008-07-27 11:54:37.000000000 +0200
++++ etc/openct.conf.in 2008-08-26 13:00:58.000000000 +0200
@@ -2,7 +2,7 @@
debug = 0;
#
# Enable hot plugging
-hotplug = yes;
+hotplug = no;
+
#
# Path to ifdhandler
- ifdhandler = SBINDIR/ifdhandler;