aboutsummaryrefslogtreecommitdiff
path: root/security/openct
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2006-11-15 06:51:23 +0000
committerAlex Dupre <ale@FreeBSD.org>2006-11-15 06:51:23 +0000
commit9a33501ba8c5f5bb81be996054fb6d443d485fe1 (patch)
tree799aeb6cdd5b7974ce5312d2ab87190c8ead714d /security/openct
parente340b5552f5e9dc8d5fa8dc83e128ce3c895823f (diff)
downloadports-9a33501ba8c5f5bb81be996054fb6d443d485fe1.tar.gz
ports-9a33501ba8c5f5bb81be996054fb6d443d485fe1.zip
Notes
Diffstat (limited to 'security/openct')
-rw-r--r--security/openct/Makefile7
-rw-r--r--security/openct/distinfo6
-rw-r--r--security/openct/files/patch-src_ifd_ifd-wbeiuu.c18
-rw-r--r--security/openct/files/patch-src_ifd_sys-bsd.c11
4 files changed, 8 insertions, 34 deletions
diff --git a/security/openct/Makefile b/security/openct/Makefile
index bbbb98169ea0..02e2d141b9a3 100644
--- a/security/openct/Makefile
+++ b/security/openct/Makefile
@@ -6,9 +6,10 @@
#
PORTNAME= openct
-PORTVERSION= 0.6.9
+DISTVERSION= 0.6.11-pre1
CATEGORIES= security
-MASTER_SITES= http://www.opensc-project.org/files/${PORTNAME}/
+MASTER_SITES= http://www.opensc-project.org/files/${PORTNAME}/ \
+ http://www.opensc-project.org/files/${PORTNAME}/testing/
MAINTAINER= ale@FreeBSD.org
COMMENT= A middleware framework for smart card terminals
@@ -27,6 +28,8 @@ SUB_FILES= etoken.conf
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --mandir=${PREFIX}/man
+
MAN1= openct-tool.1
DOC_FILES= README export-wiki.sh export-wiki.xsl trac.css *.html api
diff --git a/security/openct/distinfo b/security/openct/distinfo
index ee2977ba7435..2b72927181d8 100644
--- a/security/openct/distinfo
+++ b/security/openct/distinfo
@@ -1,3 +1,3 @@
-MD5 (openct-0.6.9.tar.gz) = 26c7f8d9fabbd698303601cc7d844252
-SHA256 (openct-0.6.9.tar.gz) = 878703c82cbc1caac996063f1efc54d1adc2b2b94a03dad97d813ca6691a6ef0
-SIZE (openct-0.6.9.tar.gz) = 665513
+MD5 (openct-0.6.11-pre1.tar.gz) = 6e19c26dd0fbab42f768a8bda0f8634f
+SHA256 (openct-0.6.11-pre1.tar.gz) = a96c5ec37818bc5c06d1e45ee7fda156790c3e0523bbbf6f7f4f0e968bd7ab75
+SIZE (openct-0.6.11-pre1.tar.gz) = 670830
diff --git a/security/openct/files/patch-src_ifd_ifd-wbeiuu.c b/security/openct/files/patch-src_ifd_ifd-wbeiuu.c
deleted file mode 100644
index cb9ec044f58f..000000000000
--- a/security/openct/files/patch-src_ifd_ifd-wbeiuu.c
+++ /dev/null
@@ -1,18 +0,0 @@
---- src/ifd/ifd-wbeiuu.c.orig Sat Oct 7 09:55:18 2006
-+++ src/ifd/ifd-wbeiuu.c Sat Oct 7 09:57:25 2006
-@@ -454,6 +454,7 @@
- {
- int status;
- unsigned char buf[256];
-+ unsigned char len;
- ifd_device_t *dev;
-
- ifd_debug(1, "%s:%d wbeiuu_card_reset()", __FILE__, __LINE__);
-@@ -504,7 +505,6 @@
- return -1;
- }
- //unsigned char len[1] = { 0x00 };
-- unsigned char len;
- ifd_debug(1, "%s:%d How many bytes waiting at the FIFO?", __FILE__,
- __LINE__, status);
- status = ifd_sysdep_usb_bulk(dev, 0x82, &len, 1, USB_TIMEOUT);
diff --git a/security/openct/files/patch-src_ifd_sys-bsd.c b/security/openct/files/patch-src_ifd_sys-bsd.c
deleted file mode 100644
index 69846e55e484..000000000000
--- a/security/openct/files/patch-src_ifd_sys-bsd.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/ifd/sys-bsd.c.orig Fri Sep 22 10:25:11 2006
-+++ src/ifd/sys-bsd.c Fri Sep 22 10:25:34 2006
-@@ -380,7 +380,7 @@
- "usb:/dev/%s", device_info.udi_devnames[0]);
- #endif /* __OpenBSD__ */
-
-- ifd_(driver, typedev, -1);
-+ ifd_spawn_handler(driver, typedev, -1);
- }
- close(controller_fd);
- }