aboutsummaryrefslogtreecommitdiff
path: root/security/openct
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-07-06 14:35:12 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-07-06 14:35:12 +0000
commit7ea7c22500d2e1c94f27b75ffee00e80dfa7e838 (patch)
tree2c170ca22682b5353aea60df5fb264672ca13ba4 /security/openct
parentce88553f7c98e7c3888c0ea2dd6b7cf18e63ea65 (diff)
downloadports-7ea7c22500d2e1c94f27b75ffee00e80dfa7e838.tar.gz
ports-7ea7c22500d2e1c94f27b75ffee00e80dfa7e838.zip
Notes
Diffstat (limited to 'security/openct')
-rw-r--r--security/openct/Makefile51
-rw-r--r--security/openct/distinfo2
-rw-r--r--security/openct/files/patch-src_ct_Makefile.in14
-rw-r--r--security/openct/pkg-descr19
-rw-r--r--security/openct/pkg-plist65
5 files changed, 151 insertions, 0 deletions
diff --git a/security/openct/Makefile b/security/openct/Makefile
new file mode 100644
index 000000000000..454c38c3db1e
--- /dev/null
+++ b/security/openct/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: openct
+# Date created: 2004-09-08
+# Whom: Janos Mohacsi <janos.mohacsi@bsd.hu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= openct
+PORTVERSION= 0.6.5
+CATEGORIES= security
+MASTER_SITES= http://www.opensc.org/files/
+
+MAINTAINER= janos.mohacsi@bsd.hu
+COMMENT= A middleware framework for smart card terminals
+
+USE_LIBTOOL_VER= 15
+USE_GMAKE= yes
+USE_GNOME= pkgconfig
+INSTALLS_SHLIB= yes
+
+CONFIGURE_ARGS= --prefix=${PREFIX}
+
+MAN1= openct-tool.1
+
+DOC_FILES= README export-wiki.sh export-wiki.xsl ${HTML_FILES}
+
+HTML_FILES= AuthorsAndCredits.html FilesTools.html LicenseText.html \
+ OperatingSystems.html QuickStart.html RecentResults.html \
+ RemoteAccess.html SecureSetup.html SupportedReaders.html \
+ TroubleShooting.html cardman.html ccid.html egate.html \
+ etoken.html eutron.html gempc.html ikey2032.html \
+ ikey3000.html index.html kaan.html smartboard.html \
+ towitoko.html trac.css
+
+.if !defined(WITHOUT_PCSC_LITE)
+LIB_DEPENDS+= pcsclite.1:${PORTSDIR}/devel/pcsc-lite
+.endif
+
+post-install:
+ #run files
+ ${MKDIR} /var/run/${PORTNAME}
+ #sample config file
+ ${INSTALL_DATA} ${WRKSRC}/etc/openct.conf ${PREFIX}/etc/openct.conf-sample
+ #start daemons script
+ ${INSTALL_SCRIPT} ${WRKSRC}/etc/init-script ${PREFIX}/etc/rc.d/openct.sh
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC}/doc && ${INSTALL_DATA} ${DOC_FILES} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/openct/distinfo b/security/openct/distinfo
new file mode 100644
index 000000000000..f604e8ceadec
--- /dev/null
+++ b/security/openct/distinfo
@@ -0,0 +1,2 @@
+MD5 (openct-0.6.5.tar.gz) = 86bafd61788139f28671872da287fa0a
+SIZE (openct-0.6.5.tar.gz) = 486355
diff --git a/security/openct/files/patch-src_ct_Makefile.in b/security/openct/files/patch-src_ct_Makefile.in
new file mode 100644
index 000000000000..ff0c47a37237
--- /dev/null
+++ b/security/openct/files/patch-src_ct_Makefile.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- src/ct/Makefile.in.orig Tue Jul 20 23:56:08 2004
++++ src/ct/Makefile.in Wed Sep 8 18:38:25 2004
+@@ -169,7 +169,7 @@
+
+ libopenct_la_LDFLAGS = -version-info @OPENCT_LT_CURRENT@:@OPENCT_LT_REVISION@:@OPENCT_LT_AGE@
+
+-pkgconfigdir = $(libdir)/pkgconfig
++pkgconfigdir = @prefix@/libdata/pkgconfig
+ pkgconfig_DATA = libopenct.pc
+ subdir = src/ct
+ ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
diff --git a/security/openct/pkg-descr b/security/openct/pkg-descr
new file mode 100644
index 000000000000..0728a71505a4
--- /dev/null
+++ b/security/openct/pkg-descr
@@ -0,0 +1,19 @@
+OpenCT, a middleware framework for smart card terminals.
+It all started with a reader driver library to provide a framework for people
+writing drivers for smart card readers. The idea was to provide all the usual
+stuff (T=0, T=1, serial vs. USB device handling, etc) in a single place, and
+reduce driver writing to interaction with the device itself.
+
+OpenCT provides a native OpenCT, CT-API and PC/SC Lite IFD interface with an
+OpenCT ifdhandler resource manager.
+
+OpenCT is an open source implementation providing card terminal drivers:
+Towitoko CHIPDRIVE micro - serial interface reader
+KOBIL KAAN Professional - serial interface reader
+Schlumberger e-gate - USB token / smart card reader
+Aladdin eToken PRO - USB crypto Token
+Eutron CryptoIdentity IT-SEC - A USB crypto Token
+Rainbow iKey 3000 - USB crypto Token
+OMNIKEY CardMan - UDB smart card reader
+
+WWW: http://www.opensc.org/
diff --git a/security/openct/pkg-plist b/security/openct/pkg-plist
new file mode 100644
index 000000000000..ab0e6d84097e
--- /dev/null
+++ b/security/openct/pkg-plist
@@ -0,0 +1,65 @@
+bin/openct-tool
+sbin/ifdhandler
+sbin/ifdproxy
+sbin/openct-control
+include/openct/apdu.h
+include/openct/buffer.h
+include/openct/conf.h
+include/openct/ctapi.h
+include/openct/device.h
+include/openct/driver.h
+include/openct/error.h
+include/openct/ifd.h
+include/openct/logging.h
+include/openct/openct.h
+include/openct/protocol.h
+include/openct/server.h
+include/openct/socket.h
+include/openct/tlv.h
+include/openct/types.h
+lib/openct-ifd.so
+lib/openct-ifd.bundle/Contents/Info.plist
+lib/openct-ifd.bundle/Contents/PkgInfo
+lib/openct-ifd.bundle/Contents/FreeBSD/openct-ifd.so
+lib/libopenct.a
+lib/libopenct.so
+lib/libopenct.so.1
+lib/libopenctapi.a
+lib/libopenctapi.so
+lib/libifd.a
+lib/libifd.so
+lib/libifd.so.1
+libdata/pkgconfig/libopenct.pc
+etc/openct.conf-sample
+etc/rc.d/openct.sh
+@dirrm include/openct/
+@dirrm lib/openct-ifd.bundle/Contents/FreeBSD/
+@dirrm lib/openct-ifd.bundle/Contents/
+@dirrm lib/openct-ifd.bundle/
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/export-wiki.sh
+%%PORTDOCS%%%%DOCSDIR%%/export-wiki.xsl
+%%PORTDOCS%%%%DOCSDIR%%/AuthorsAndCredits.html
+%%PORTDOCS%%%%DOCSDIR%%/FilesTools.html
+%%PORTDOCS%%%%DOCSDIR%%/LicenseText.html
+%%PORTDOCS%%%%DOCSDIR%%/OperatingSystems.html
+%%PORTDOCS%%%%DOCSDIR%%/QuickStart.html
+%%PORTDOCS%%%%DOCSDIR%%/RecentResults.html
+%%PORTDOCS%%%%DOCSDIR%%/RemoteAccess.html
+%%PORTDOCS%%%%DOCSDIR%%/SecureSetup.html
+%%PORTDOCS%%%%DOCSDIR%%/SupportedReaders.html
+%%PORTDOCS%%%%DOCSDIR%%/TroubleShooting.html
+%%PORTDOCS%%%%DOCSDIR%%/cardman.html
+%%PORTDOCS%%%%DOCSDIR%%/ccid.html
+%%PORTDOCS%%%%DOCSDIR%%/egate.html
+%%PORTDOCS%%%%DOCSDIR%%/etoken.html
+%%PORTDOCS%%%%DOCSDIR%%/eutron.html
+%%PORTDOCS%%%%DOCSDIR%%/gempc.html
+%%PORTDOCS%%%%DOCSDIR%%/ikey2032.html
+%%PORTDOCS%%%%DOCSDIR%%/ikey3000.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/kaan.html
+%%PORTDOCS%%%%DOCSDIR%%/smartboard.html
+%%PORTDOCS%%%%DOCSDIR%%/towitoko.html
+%%PORTDOCS%%%%DOCSDIR%%/trac.css
+%%PORTDOCS%%@dirrm %%DOCSDIR%%