aboutsummaryrefslogtreecommitdiff
path: root/security/openfwtk/Makefile
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2014-07-24 18:36:19 +0000
committerRene Ladan <rene@FreeBSD.org>2014-07-24 18:36:19 +0000
commit36e34f48e2e5ab984eb31b7cff1ee163494523f0 (patch)
tree78419497b9b7f06ed2367445df2b7045727c6e0a /security/openfwtk/Makefile
parent37f54e0f66813dcddb3659fd7810198377792a1e (diff)
Notes
Diffstat (limited to 'security/openfwtk/Makefile')
-rw-r--r--security/openfwtk/Makefile82
1 files changed, 0 insertions, 82 deletions
diff --git a/security/openfwtk/Makefile b/security/openfwtk/Makefile
deleted file mode 100644
index 3aba294a3e89..000000000000
--- a/security/openfwtk/Makefile
+++ /dev/null
@@ -1,82 +0,0 @@
-# Created by: Anton Karpov <toxa@toxahost.ru>
-# $FreeBSD$
-
-PORTNAME= openfwtk
-PORTVERSION= 2.0
-PORTREVISION= 1
-CATEGORIES= security
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/Release%20${PORTVERSION}
-DISTNAME= ${PORTNAME}${PORTVERSION}
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Application proxy toolkit which inherits the ideology of TIS fwtk
-
-LICENSE= BSD
-
-DEPRECATED= Fails to build with new utmpx
-EXPIRATION_DATE= 2014-07-23
-
-OPTIONS_DEFINE= GUI
-GUI_DESC= Install fw-watch GUI (require TCL/TK!)
-
-WRKSRC= ${WRKDIR}/fwtk
-WRKSRC_WATCH= ${WRKDIR}/fw_watch
-WRKSRC_MILTER= ${WRKDIR}/libci_milter
-
-MAKE_JOBS_UNSAFE=yes
-
-SUB_FILES= pkg-message
-MANCOMPRESSED= no
-
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MGUI}
-USES+= tk:wrapper
-PLIST_SUB+= WATCH=""
-.else
-PLIST_SUB+= WATCH="@comment "
-.endif
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} > 900007
-BROKEN= fails to build with new utmpx
-.endif
-
-post-patch:
-.for conf in auth/authadduser.sh reports/summ_resources.sh \
- reports/daily_report reports/frequentcheck \
- reports/frequentcheck.sh squid-gw/squid-gw.restart
- @${REINPLACE_CMD} -e \
- 's|/etc/openfwtk.conf|${PREFIX}/etc/openfwtk.conf|g' ${WRKSRC}/${conf}
-.endfor
-.for wish in fileselect.tcl fw_watch
- @${REINPLACE_CMD} -e \
- 's|/usr/bin/|${LOCALBASE}/bin/|g' ${WRKSRC_WATCH}/${wish}
-.endfor
- @${REINPLACE_CMD} -e \
- '/^CC/s|=.*|= ${CC}|g ; \
- /^COPT/s|=.*|= ${CFLAGS}|g' ${WRKSRC_MILTER}/Makefile
- @${REINPLACE_CMD} -e \
- '/^CC/s|=.*|= ${CC}|g ; \
- /^COPT/s|-std=c99|${CFLAGS}|g' ${WRKSRC}/configs/FreeBSD
-
-pre-build:
- @(cd ${WRKSRC_MILTER}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET})
-
-pre-install:
- @${MKDIR} ${ETCDIR}
-
-post-install:
-.if ${PORT_OPTIONS:MGUI}
- @${MKDIR} ${PREFIX}/share/fw_watch
-.for data in fileselect.tcl fw_watch newsb.tcl searchbox.tcl taputils.tcl
- ${INSTALL_DATA} ${WRKSRC_WATCH}/${data} ${PREFIX}/share/fw_watch
-.endfor
-.endif
- ${ECHO_CMD} "root@`hostname`" > ${ETCDIR}/admin
- @${CAT} ${PKGMESSAGE}
-
-.include "Makefile.man"
-.include <bsd.port.post.mk>