aboutsummaryrefslogtreecommitdiff
path: root/security/openpgpsdk
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-02-10 11:27:57 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-02-10 11:27:57 +0000
commit72cb71315ec36f68d2381d5f52de259ea8ddb2df (patch)
tree07e7773817314e13eb504aa044281562aa025c69 /security/openpgpsdk
parentafcc89c7c99d2b59dff920e004ae0673ae00ed5d (diff)
downloadports-72cb71315ec36f68d2381d5f52de259ea8ddb2df.tar.gz
ports-72cb71315ec36f68d2381d5f52de259ea8ddb2df.zip
Notes
Diffstat (limited to 'security/openpgpsdk')
-rw-r--r--security/openpgpsdk/Makefile36
-rw-r--r--security/openpgpsdk/distinfo3
-rw-r--r--security/openpgpsdk/pkg-descr4
3 files changed, 43 insertions, 0 deletions
diff --git a/security/openpgpsdk/Makefile b/security/openpgpsdk/Makefile
new file mode 100644
index 000000000000..40bc914256d3
--- /dev/null
+++ b/security/openpgpsdk/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: openpgpsdk
+# Date created: 2009-02-10
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= openpgpsdk
+PORTVERSION= 0.9
+CATEGORIES= security
+MASTER_SITES= http://openpgp.nominet.org.uk/downloads/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= OpenPGP SDK
+
+BUILD_DEPENDS= gpg2:${PORTSDIR}/security/gnupg
+LIB_DEPENDS= cunit.1:${PORTSDIR}/devel/cunit
+
+USE_PERL5= yes
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --without-idea --with-cunit=${LOCALBASE}
+
+PLIST_FILES= bin/openpgp lib/libops.a
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700042
+BROKEN= does not build on 6.x.
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/openpgp ${PREFIX}/bin/
+ ${INSTALL_DATA} ${WRKSRC}/lib/libops.a ${PREFIX}/lib/
+
+.include <bsd.port.post.mk>
diff --git a/security/openpgpsdk/distinfo b/security/openpgpsdk/distinfo
new file mode 100644
index 000000000000..29f1a9cd4518
--- /dev/null
+++ b/security/openpgpsdk/distinfo
@@ -0,0 +1,3 @@
+MD5 (openpgpsdk-0.9.tgz) = a2fe87ee864e6bcc0d5ea3db20e0f57a
+SHA256 (openpgpsdk-0.9.tgz) = 96ad3196205d323818f7175e24f7e3a227c90f76eb308c0ebaae0de26b7c2376
+SIZE (openpgpsdk-0.9.tgz) = 1903992
diff --git a/security/openpgpsdk/pkg-descr b/security/openpgpsdk/pkg-descr
new file mode 100644
index 000000000000..6b514041fc10
--- /dev/null
+++ b/security/openpgpsdk/pkg-descr
@@ -0,0 +1,4 @@
+The OpenPGP SDK project provides an open source library, written in C,
+which implements the OpenPGP specification.
+
+WWW: http://openpgp.nominet.org.uk/