aboutsummaryrefslogtreecommitdiff
path: root/security/opensaml2
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-02-14 23:12:25 +0000
committerRong-En Fan <rafan@FreeBSD.org>2007-02-14 23:12:25 +0000
commit504bdbc0609438e4c9817cfbbad87d69d36c2435 (patch)
treeb1c425bdaab81c646b570fa4897f525ae358be1b /security/opensaml2
parent74f1a459117ec32b88ac03443c0b1c8a0b885f73 (diff)
downloadports-504bdbc0609438e4c9817cfbbad87d69d36c2435.tar.gz
ports-504bdbc0609438e4c9817cfbbad87d69d36c2435.zip
Notes
Diffstat (limited to 'security/opensaml2')
-rw-r--r--security/opensaml2/Makefile35
-rw-r--r--security/opensaml2/distinfo3
-rw-r--r--security/opensaml2/files/patch-configure17
-rw-r--r--security/opensaml2/pkg-descr4
-rw-r--r--security/opensaml2/pkg-plist29
5 files changed, 88 insertions, 0 deletions
diff --git a/security/opensaml2/Makefile b/security/opensaml2/Makefile
new file mode 100644
index 000000000000..16e5e2f45494
--- /dev/null
+++ b/security/opensaml2/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: opensaml
+# Date created: 06 Febuary 2007
+# Whom: Tony Maher
+#
+# $FreeBSD$
+#
+
+PORTNAME= opensaml
+PORTVERSION= 1.1
+CATEGORIES= security
+MASTER_SITES= http://shibboleth.internet2.edu/downloads/
+
+MAINTAINER= tonymaher@optusnet.com.au
+COMMENT= Open source implentation of SAML
+
+LIB_DEPENDS= curl.4:${PORTSDIR}/ftp/curl \
+ log4cpp.4:${PORTSDIR}/devel/log4cpp \
+ xerces-c.27:${PORTSDIR}/textproc/xerces-c2 \
+ xml-security-c.13:${PORTSDIR}/security/apache-xml-security-c
+
+GNU_CONFIGURE= yes
+USE_AUTOTOOLS= libtool:15
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,^pkgdocdir.*=.*,pkgdocdir = ${DOCSDIR},' \
+ ${WRKSRC}/doc/Makefile.in
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e '/^SUBDIRS/s,doc ,,' ${WRKSRC}/Makefile.in
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/opensaml2/distinfo b/security/opensaml2/distinfo
new file mode 100644
index 000000000000..2124f3f99730
--- /dev/null
+++ b/security/opensaml2/distinfo
@@ -0,0 +1,3 @@
+MD5 (opensaml-1.1.tar.gz) = 060443b7e7419c186c3add38a5c726f7
+SHA256 (opensaml-1.1.tar.gz) = fa8f1383dd6b5b88e1ad4525c5b7b687ef4285fc063272f141ef61f9876503d0
+SIZE (opensaml-1.1.tar.gz) = 466921
diff --git a/security/opensaml2/files/patch-configure b/security/opensaml2/files/patch-configure
new file mode 100644
index 000000000000..bcfb1d6a0e39
--- /dev/null
+++ b/security/opensaml2/files/patch-configure
@@ -0,0 +1,17 @@
+--- configure.orig Mon Feb 12 12:13:21 2007
++++ configure Mon Feb 12 12:13:27 2007
+@@ -20574,8 +20574,12 @@
+ fi;
+ SSLLIBS="$SSLLIBS -lssl -lcrypto"
+ else
+- SSLLIBS="`$PKG_CONFIG --libs openssl`"
+- SSLFLAGS="`$PKG_CONFIG --cflags openssl`"
++ if `$PKG_CONFIG --libs openssl >> /dev/null 2>&1`; then
++ SSLLIBS="`$PKG_CONFIG --libs openssl`"
++ SSLFLAGS="`$PKG_CONFIG --cflags openssl`"
++ else
++ SSLLIBS="$SSLLIBS -lssl -lcrypto"
++ fi
+ fi
+ echo "$as_me:$LINENO: checking for OpenSSL libraries" >&5
+ echo $ECHO_N "checking for OpenSSL libraries... $ECHO_C" >&6
diff --git a/security/opensaml2/pkg-descr b/security/opensaml2/pkg-descr
new file mode 100644
index 000000000000..a116fd2012fe
--- /dev/null
+++ b/security/opensaml2/pkg-descr
@@ -0,0 +1,4 @@
+OpenSAML is an implementation of SAML 1.0 and 1.1 providing java and C++
+APIs. This is the C++ version.
+
+WWW: https://spaces.internet2.edu/display/SHIB/OpenSAML
diff --git a/security/opensaml2/pkg-plist b/security/opensaml2/pkg-plist
new file mode 100644
index 000000000000..5af54f11ccaa
--- /dev/null
+++ b/security/opensaml2/pkg-plist
@@ -0,0 +1,29 @@
+bin/signtest
+include/saml/SAMLDateTime.h
+include/saml/config_pub.h
+include/saml/hresult.h
+include/saml/saml.h
+include/saml/version.h
+lib/libsaml.a
+lib/libsaml.so
+lib/libsaml.so.5
+%%PORTDOCS%%%%DOCSDIR%%/CURL.LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL-WIN32.txt
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL.txt
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE.txt
+%%PORTDOCS%%%%DOCSDIR%%/LOG4CPP.LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/NEWS.txt
+%%PORTDOCS%%%%DOCSDIR%%/NOTICE.txt
+%%PORTDOCS%%%%DOCSDIR%%/OPENSSL.LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/README.txt
+%%PORTDOCS%%%%DOCSDIR%%/TODO.txt
+share/xml/opensaml/cs-sstc-schema-assertion-01.xsd
+share/xml/opensaml/cs-sstc-schema-assertion-1.1.xsd
+share/xml/opensaml/cs-sstc-schema-protocol-01.xsd
+share/xml/opensaml/cs-sstc-schema-protocol-1.1.xsd
+share/xml/opensaml/soap-envelope.xsd
+share/xml/opensaml/xml.xsd
+share/xml/opensaml/xmldsig-core-schema.xsd
+@dirrm include/saml
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm share/xml/opensaml