aboutsummaryrefslogtreecommitdiff
path: root/security/opensc-esteid/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-10-07 23:34:40 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-10-07 23:34:40 +0000
commit867f451ee77856eef9e1595ba08a990dc0c25c12 (patch)
tree261b0b39374af69517789850245bfc0a5ed44f5c /security/opensc-esteid/Makefile
parent483cf5f9bb013eabecfb6c1d87d2aacfff6055f1 (diff)
[new port] security/opensc-esteid: modified version of the
security/opensc port that works with Estonian Electronic ID card This is modified version of the OpenSC port that works with Estonian Electronic ID card (EstEID). WWW: http://marie.vtl.ee/esteid/ PR: ports/56612 Submitted by: Sven Petai <hadara@bsd.ee>
Notes
Notes: svn path=/head/; revision=90566
Diffstat (limited to 'security/opensc-esteid/Makefile')
-rw-r--r--security/opensc-esteid/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/security/opensc-esteid/Makefile b/security/opensc-esteid/Makefile
new file mode 100644
index 000000000000..0b987250b79f
--- /dev/null
+++ b/security/opensc-esteid/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: opensc-esteid
+# Date created: 8 September 2003
+# Whom: Sven Petai <hadara@bsd.ee>
+#
+# $FreeBSD$
+#
+
+PORTNAME= esteid
+PORTVERSION= 0.7.0.1
+CATEGORIES= security devel
+MASTER_SITES= http://marie.vtl.ee/esteid/
+PKGNAMEPREFIX= opensc-
+DISTNAME= opensc-esteid-0.7.0-1
+
+MAINTAINER= hadara@bsd.ee
+COMMENT= ISO 7816 Smartcard API Library (OpenSSH Compatible)
+
+LIB_DEPENDS= pcsclite.0:${PORTSDIR}/devel/pcsc-lite
+
+USE_OPENLDAP_VER= 20
+INSTALLS_SHLIB= yes
+USE_OPENSSL= yes
+USE_LIBTOOL= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-pcsclite=${LOCALBASE} \
+ --with-ldap-lib=openldap \
+ --with-ldap-dir=${LOCALBASE} \
+ --with-plugin-dir=${LOCALBASE}/share/opensc/plugins
+
+MAN1= pkcs15-crypt.1 pkcs15-init.1 pkcs15-tool.1 \
+ cryptoflex-tool.1 \
+ opensc-config.1 opensc-explorer.1 opensc-tool.1
+MAN5= pkcs15-profile.5
+MAN7= pkcs15.7 opensc.7
+
+.include <bsd.port.mk>