aboutsummaryrefslogtreecommitdiff
path: root/security/opensc/Makefile
diff options
context:
space:
mode:
authorBruce M Simpson <bms@FreeBSD.org>2005-01-14 15:08:23 +0000
committerBruce M Simpson <bms@FreeBSD.org>2005-01-14 15:08:23 +0000
commit3074e4d23ea791aaea987b8bcd8046086cb7ae64 (patch)
treeeb99b916237066ad45a645a5fcff1e9227202768 /security/opensc/Makefile
parent15e81066dc4484d34b0356fccb92b49955327ea2 (diff)
Notes
Diffstat (limited to 'security/opensc/Makefile')
-rw-r--r--security/opensc/Makefile39
1 files changed, 26 insertions, 13 deletions
diff --git a/security/opensc/Makefile b/security/opensc/Makefile
index d3aef2cd0033..a6d3d3f59dd2 100644
--- a/security/opensc/Makefile
+++ b/security/opensc/Makefile
@@ -6,24 +6,24 @@
#
PORTNAME= opensc
-PORTVERSION= 0.8.1
-PORTREVISION= 1
+PORTVERSION= 0.9.4
CATEGORIES= security devel
MASTER_SITES= http://www.opensc.org/files/
MAINTAINER= bms@FreeBSD.org
COMMENT= ISO 7816 Smartcard API
-RUN_DEPENDS= ${LOCALBASE}/bin/pkg-config:${PORTSDIR}/devel/pkgconfig
-
-INSTALLS_SHLIB= yes
+USE_GNOME= pkgconfig
+INSTALLS_SHLIB= yes
USE_OPENSSL= yes
USE_GMAKE= yes
+USE_LIBTOOL_VER= 15
GNU_CONFIGURE= yes
MANCOMPRESSED= no
MAN1= pkcs15-crypt.1 pkcs15-init.1 pkcs15-tool.1 opensc-tool.1 \
- opensc-explorer.1 opensc-config.1 cryptoflex-tool.1
+ opensc-explorer.1 opensc-config.1 cryptoflex-tool.1 \
+ pkcs11-tool.1 cardos-info.1
MAN3= sc_select_file.3 sc_release_context.3 sc_read_record.3 \
sc_read_binary.3 sc_pkcs15_compute_signature.3 sc_lock.3 \
sc_list_files.3 sc_file_new.3 sc_file_free.3 sc_file.3 \
@@ -36,7 +36,7 @@ MAN7= pkcs15.7 opensc.7
#
# Define boolean switches:
# WITHOUT_PAM WITHOUT_PCSC_LITE WITHOUT_LDAP
-# WITH_USBTOKEN WITH_DOCBOOK WITH_MOZILLA
+# WITH_DEBUG WITH_DOCBOOK WITH_FIREFOX_PLUGIN WITH_MOZILLA_PLUGIN
#
# Default: WITH_PAM, WITH_PCSC_LITE, WITH_LDAP.
#
@@ -45,6 +45,7 @@ CONFIGURE_ARGS= --prefix=${PREFIX} --disable-dependency-tracking
.if !defined(WITHOUT_PAM)
CONFIGURE_ARGS+= --with-pam
.endif
+
.if !defined(WITHOUT_PCSC_LITE)
LIB_DEPENDS+= pcsclite.0:${PORTSDIR}/devel/pcsc-lite
CONFIGURE_ARGS+= --with-pcsclite=${LOCALBASE}
@@ -55,20 +56,32 @@ USE_OPENLDAP= yes
CONFIGURE_ARGS+= --enable-ldap \
--with-ldap-lib=openldap \
--with-ldap-dir=${LOCALBASE}
+PLIST_SUB+= LDAP=""
.else
CONFIGURE_ARGS+= --disable-ldap
+PLIST_SUB+= LDAP="@comment "
+.endif
+
+.if defined(WITH_FIREFOX_PLUGIN)
+RUN_DEPENDS?= firefox:${PORTSDIR}/www/firefox
+PLUGIN_DIR?= lib/firefox/plugins
+CONFIGURE_ARGS+= --with-plugin-dir="${PREFIX}/${PLUGIN_DIR}"
+.elif defined(WITH_MOZILLA_PLUGIN)
+RUN_DEPENDS?= mozilla:${PORTSDIR}/www/mozilla
+PLUGIN_DIR?= lib/browser_plugins
+CONFIGURE_ARGS+= --with-plugin-dir="${PREFIX}/${PLUGIN_DIR}"
+.endif
+
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+= --enable-debug
.endif
.if !defined(WITH_DOCBOOK)
CONFIGURE_ARGS+= --without-docbook
.endif
-# XXX USB token support doesn't work yet on FreeBSD. Accepting patches.
-.if defined(WITH_USBTOKEN)
-CONFIGURE_ARGS+= --enable-usbtoken
-.endif
-.if defined(WITH_MOZILLA)
-CONFIGURE_ARGS+= --with-plugin-dir=${X11BASE}/lib/mozilla/plugins
+.if defined(WITH_OPENCT)
+CONFIGURE_ARGS+= --with-openct=${LOCALBASE}
.endif
.include <bsd.port.pre.mk>