aboutsummaryrefslogtreecommitdiff
path: root/security/openssh-portable/Makefile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2004-08-18 11:35:53 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2004-08-18 11:35:53 +0000
commit7fbc51cf8f84b316fd2fb689bba9afa4bd31a448 (patch)
tree6ecfba3259f0d4f327b52e20519328f7d9bc7e0f /security/openssh-portable/Makefile
parent1ad5c7328f0e8f99e03e74fa0fe83978ee0b6899 (diff)
downloadports-7fbc51cf8f84b316fd2fb689bba9afa4bd31a448.tar.gz
ports-7fbc51cf8f84b316fd2fb689bba9afa4bd31a448.zip
Notes
Diffstat (limited to 'security/openssh-portable/Makefile')
-rw-r--r--security/openssh-portable/Makefile26
1 files changed, 23 insertions, 3 deletions
diff --git a/security/openssh-portable/Makefile b/security/openssh-portable/Makefile
index ff013ce24442..0a642dd70d07 100644
--- a/security/openssh-portable/Makefile
+++ b/security/openssh-portable/Makefile
@@ -6,16 +6,33 @@
#
PORTNAME= openssh
-PORTVERSION= 3.8.1p1
+PORTVERSION= 3.9.0.1
+.if defined(OPENSSH_SNAPSHOT)
+PORTREVISION!= date -v-1d +%Y%m%d
+.endif
PORTEPOCH= 1
CATEGORIES= security ipv6
-MASTER_SITES= ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/ \
- ftp://carroll.cac.psu.edu/pub/OpenBSD/OpenSSH/portable/
+MASTER_SITES= ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%SUBDIR%/ \
+ ftp://carroll.cac.psu.edu/pub/OpenBSD/OpenSSH/portable/%SUBDIR%/
PKGNAMESUFFIX?= ${PORTABLE_SUFFIX}${GSSAPI_SUFFIX}${BASE_SUFFIX}${PKGNAMESUFFIX2}
+MASTER_SITE_SUBDIR= ${MASTER_SITE_SUBDIR2}
+DISTNAME= ${DISTNAME2}
MAINTAINER= dinoex@FreeBSD.org
COMMENT= The portable version of OpenBSD's OpenSSH
+OPENSSHVERSION= 3.9p1
+.if defined(OPENSSH_SNAPSHOT)
+MASTER_SITE_SUBDIR2= snapshot/
+DISTNAME2= ${PORTNAME}-SNAP-${PORTREVISION}
+NO_CHECKSUM= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+.else
+MASTER_SITE_SUBDIR2=
+DISTNAME2= ${PORTNAME}-${OPENSSHVERSION}
+WRKSRC= ${WRKDIR}/${PORTNAME}-${OPENSSHVERSION}
+.endif
+
MAN1= sftp.1 ssh-add.1 ssh-agent.1 ssh-keygen.1 ssh-keyscan.1 scp.1 ssh.1
MLINKS= ssh.1 slogin.1
MAN5= ssh_config.5 sshd_config.5
@@ -130,6 +147,9 @@ test:
.include <bsd.port.pre.mk>
+SUDO?=
+MAKE_ENV+= SUDO="${SUDO}"
+
.if defined(KRB5_HOME) && exists(${KRB5_HOME}) || defined(WITH_GSSAPI)
.if ${OPENSSLBASE} == "/usr"
CONFIGURE_ARGS+= --without-rpath