aboutsummaryrefslogtreecommitdiff
path: root/security/openssh-portable/Makefile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2004-02-26 05:56:07 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2004-02-26 05:56:07 +0000
commit4857d67313d15b09e0eb7e78bbcf35759b2c8544 (patch)
tree29e66fbfae1297f0acf1c5d6d77f5a3374a4bafa /security/openssh-portable/Makefile
parentc600b831917ce7ab0fef85718f47bd82a6264fb3 (diff)
downloadports-4857d67313d15b09e0eb7e78bbcf35759b2c8544.tar.gz
ports-4857d67313d15b09e0eb7e78bbcf35759b2c8544.zip
Notes
Diffstat (limited to 'security/openssh-portable/Makefile')
-rw-r--r--security/openssh-portable/Makefile32
1 files changed, 16 insertions, 16 deletions
diff --git a/security/openssh-portable/Makefile b/security/openssh-portable/Makefile
index 356201652c55..5589503372f9 100644
--- a/security/openssh-portable/Makefile
+++ b/security/openssh-portable/Makefile
@@ -45,6 +45,22 @@ CONFIGURE_ARGS+= --with-tcp-wrappers
CONFIGURE_ARGS+= --disable-suid-ssh
.endif
+.if defined(KRB5_HOME) && exists(${KRB5_HOME})
+PKGNAMESUFFIX= -gssapi
+CONFLICTS+= openssh-portable-*
+CONFIGURE_ARGS+= --with-kerberos5=${KRB5_HOME}
+.else
+CONFLICTS+= openssh-gssapi-*
+.if !defined(WITHOUT_KERBEROS) && exists(/usr/include/krb5.h)
+CONFIGURE_ARGS+= --with-kerberos5
+EXTRA_PATCHES+= ${FILESDIR}/gss-serv.c.patch
+.endif
+.endif
+
+.if defined(BATCH)
+EXTRA_PATCHES+= ${FILESDIR}/batch.patch
+.endif
+
.if defined(OPENSSH_OVERWRITE_BASE)
WITH_OPENSSL_BASE= yes
PKGNAMESUFFIX= -overwrite-base
@@ -70,22 +86,6 @@ PLIST_SUB+= EMPTYDIR=${EMPTYDIR}
CONFIGURE_ARGS+= --sysconfdir=${ETCSSH}
CONFIGURE_ARGS+= --with-privsep-path=${EMPTYDIR}
-.if defined(BATCH)
-EXTRA_PATCHES+= ${FILESDIR}/batch.patch
-.endif
-
-.if defined(KRB5_HOME) && exists(${KRB5_HOME})
-PKGNAMESUFFIX= -gssapi
-CONFLICTS+= openssh-portable-*
-CONFIGURE_ARGS+= --with-kerberos5=${KRB5_HOME}
-.else
-CONFLICTS+= openssh-gssapi-*
-.if !defined(WITHOUT_KERBEROS) && exists(/usr/include/krb5.h)
-CONFIGURE_ARGS+= --with-kerberos5
-EXTRA_PATCHES+= ${FILESDIR}/gss-serv.c.patch
-.endif
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|-ldes||g' ${WRKSRC}/configure