aboutsummaryrefslogtreecommitdiff
path: root/security/openssh-portable
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2018-06-26 22:32:37 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2018-06-26 22:32:37 +0000
commitad7e8762a992a07c760aa722043f242a96540770 (patch)
tree385c030016ae36a690f9c29c410620cf77e7ad1f /security/openssh-portable
parent0f8a7c05f8b15b817a59354943f14bb1578531aa (diff)
downloadports-ad7e8762a992a07c760aa722043f242a96540770.tar.gz
ports-ad7e8762a992a07c760aa722043f242a96540770.zip
Notes
Diffstat (limited to 'security/openssh-portable')
-rw-r--r--security/openssh-portable/Makefile4
-rw-r--r--security/openssh-portable/distinfo4
-rw-r--r--security/openssh-portable/files/extra-patch-x509-glue34
3 files changed, 38 insertions, 4 deletions
diff --git a/security/openssh-portable/Makefile b/security/openssh-portable/Makefile
index 8794fae638fd..0bb1526ea812 100644
--- a/security/openssh-portable/Makefile
+++ b/security/openssh-portable/Makefile
@@ -3,7 +3,7 @@
PORTNAME= openssh
DISTVERSION= 7.7p1
-PORTREVISION= 3
+PORTREVISION= 4
PORTEPOCH= 1
CATEGORIES= security ipv6
MASTER_SITES= OPENBSD/OpenSSH/portable
@@ -62,7 +62,7 @@ HPN_CONFIGURE_WITH= hpn
NONECIPHER_CONFIGURE_WITH= nonecipher
# See http://www.roumenpetrov.info/openssh/
-X509_VERSION= 11.3
+X509_VERSION= 11.3.2
X509_PATCH_SITES= http://www.roumenpetrov.info/openssh/x509-${X509_VERSION}/:x509
X509_EXTRA_PATCHES+= ${FILESDIR}/extra-patch-x509-glue
X509_PATCHFILES= ${PORTNAME}-7.7p1+x509-${X509_VERSION}.diff.gz:-p1:x509
diff --git a/security/openssh-portable/distinfo b/security/openssh-portable/distinfo
index 1efd65c44e34..aa8795c30a97 100644
--- a/security/openssh-portable/distinfo
+++ b/security/openssh-portable/distinfo
@@ -1,7 +1,7 @@
TIMESTAMP = 1524589531
SHA256 (openssh-7.7p1.tar.gz) = d73be7e684e99efcd024be15a30bffcbe41b012b2f7b3c9084aed621775e6b8f
SIZE (openssh-7.7p1.tar.gz) = 1536900
-SHA256 (openssh-7.7p1+x509-11.3.diff.gz) = 57be0d0028863f1f690b8b4ccae7583c0f8dd8ed2c688a912b25832bf7f9b185
-SIZE (openssh-7.7p1+x509-11.3.diff.gz) = 488467
+SHA256 (openssh-7.7p1+x509-11.3.2.diff.gz) = f0549007b2bdb99c41d83e622b6504365a3fa0a5ac22e3d0755c89cb0e29a02f
+SIZE (openssh-7.7p1+x509-11.3.2.diff.gz) = 492142
SHA256 (openssh-7.7p1-gsskex-all-20141021-debian-rh-20171004.patch.gz) = c58f10ed5d9550e6e4ac09898a1aa131321e69c4d65a742ab95d357b35576ef4
SIZE (openssh-7.7p1-gsskex-all-20141021-debian-rh-20171004.patch.gz) = 27251
diff --git a/security/openssh-portable/files/extra-patch-x509-glue b/security/openssh-portable/files/extra-patch-x509-glue
index 5ff2eefcbf4d..21a08e6e8f2a 100644
--- a/security/openssh-portable/files/extra-patch-x509-glue
+++ b/security/openssh-portable/files/extra-patch-x509-glue
@@ -155,3 +155,37 @@
.Ev DISPLAY
environment variable to
.Cm localhost .
+--- openbsd-compat/port-net.c 2018-06-26 15:18:43.551904000 -0700
++++ openbsd-compat/port-net.c.orig 2018-04-01 22:38:28.000000000 -0700
+@@ -186,8 +185,8 @@ sys_tun_open(int tun, int mode, char **ifname)
+ else
+ debug("%s: %s mode %d fd %d", __func__, ifr.ifr_name, mode, fd);
+
+- if (ifname != NULL)
+- *ifname = xstrdup(ifr.ifr_name);
++ if (ifname != NULL && (*ifname = strdup(ifr.ifr_name)))
++ goto failed;
+
+ return (fd);
+
+@@ -273,8 +272,8 @@ sys_tun_open(int tun, int mode, char **ifname)
+ goto failed;
+ }
+
+- if (ifname != NULL)
+- *ifname = xstrdup(ifr.ifr_name);
++ if (ifname != NULL && (*ifname = strdup(ifr.ifr_name)))
++ goto failed;
+
+ close(sock);
+ return (fd);
+--- ssh.c.orig 2018-04-01 22:38:28.000000000 -0700
++++ ssh.c 2018-06-26 15:22:02.947595000 -0700
+@@ -1411,6 +1323,7 @@ main(int ac, char **av)
+ (char *)NULL);
+ free(cp);
+ }
++ free(conn_hash_hex);
+
+ if (config_test) {
+ dump_client_config(&options, host);