aboutsummaryrefslogtreecommitdiff
path: root/security/openssh-portable
diff options
context:
space:
mode:
authorJacques Vidrine <nectar@FreeBSD.org>2002-03-06 13:53:39 +0000
committerJacques Vidrine <nectar@FreeBSD.org>2002-03-06 13:53:39 +0000
commit1a07b54104300bf39daf82d5c3a7913fe61b047d (patch)
treefa710c1ebba8d6648a3264eedb1a514d6971a6cd /security/openssh-portable
parente5e39fa30c66d1897d8fc0ecb1960c014afbfa0c (diff)
downloadports-1a07b54104300bf39daf82d5c3a7913fe61b047d.tar.gz
ports-1a07b54104300bf39daf82d5c3a7913fe61b047d.zip
Notes
Diffstat (limited to 'security/openssh-portable')
-rw-r--r--security/openssh-portable/Makefile1
-rw-r--r--security/openssh-portable/files/patch-channels.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/security/openssh-portable/Makefile b/security/openssh-portable/Makefile
index 8d6fe1acf548..0412868bda3d 100644
--- a/security/openssh-portable/Makefile
+++ b/security/openssh-portable/Makefile
@@ -7,6 +7,7 @@
PORTNAME= openssh
PORTVERSION= 3.0.2p1
+PORTREVISION= 1
CATEGORIES= security ipv6
MASTER_SITES= ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/ \
ftp://ftp.op.net/pub/OpenBSD/OpenSSH/portable/ \
diff --git a/security/openssh-portable/files/patch-channels.c b/security/openssh-portable/files/patch-channels.c
new file mode 100644
index 000000000000..fc11fc9c6bad
--- /dev/null
+++ b/security/openssh-portable/files/patch-channels.c
@@ -0,0 +1,11 @@
+--- channels.c.orig Wed Oct 10 17:18:47 2001
++++ channels.c Wed Mar 6 07:49:46 2002
+@@ -145,7 +145,7 @@
+ {
+ Channel *c;
+
+- if (id < 0 || id > channels_alloc) {
++ if (id < 0 || id >= channels_alloc) {
+ log("channel_lookup: %d: bad id", id);
+ return NULL;
+ }