aboutsummaryrefslogtreecommitdiff
path: root/security/openssl-beta/Makefile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2002-08-14 19:48:07 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2002-08-14 19:48:07 +0000
commit5d48c3b46fff0f50118b895926e87519586e673d (patch)
treef2dede5d52afee6cb97aca09971f47a784ff7124 /security/openssl-beta/Makefile
parent31eafb38ea5afab5018760e8d526320bb576f370 (diff)
Update to openssl-0.9.7-beta3 after repro-copy, use at own risk.
Notes
Notes: svn path=/head/; revision=64516
Diffstat (limited to 'security/openssl-beta/Makefile')
-rw-r--r--security/openssl-beta/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/security/openssl-beta/Makefile b/security/openssl-beta/Makefile
index 175444a02ffc..99c4305cf28f 100644
--- a/security/openssl-beta/Makefile
+++ b/security/openssl-beta/Makefile
@@ -6,7 +6,8 @@
#
PORTNAME= openssl
-PORTVERSION= 0.9.6g
+PKGNAMESUFFIX= -beta
+PORTVERSION= 0.9.7-beta3
CATEGORIES= security devel
MASTER_SITES= http://www.openssl.org/source/ \
ftp://ftp.openssl.org/source/ \
@@ -35,11 +36,12 @@ INSTALLS_SHLIB= yes
.endif
.if defined(OPENSSL_OVERWRITE_BASE)
-PKGNAMESUFFIX= -overwrite-base
+PKGNAMESUFFIX= -beta-overwrite-base
PREFIX= /usr
SHLIBVER= 2
.endif
+NO_LATEST_LINK= yes
MANPREFIX= ${PREFIX}/openssl
MAN1= CA.pl.1 asn1parse.1 ca.1 ciphers.1 crl.1 crl2pkcs7.1 dgst.1 \
@@ -117,6 +119,11 @@ MAN5= config.5
MAN7= des_modes.7
+MAN1+= ocsp.1
+MAN3+= BN_swap.3 EVP_BytesToKey.3 SSL_CTX_set_generate_session_id.3 \
+ SSL_CTX_set_max_cert_list.3 SSL_CTX_set_msg_callback.3 \
+ pem.3 ui.3 ui_compat.3
+
.if defined(BATCH) || defined(OPENSSL_WITH_386)
EXTRACONFIGURE= 386
.endif