aboutsummaryrefslogtreecommitdiff
path: root/security/openssl-beta
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2002-05-31 20:51:48 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2002-05-31 20:51:48 +0000
commit65e2b09e203793a4b84951b457e7e73247c06db1 (patch)
tree26edfe514e1fc4e2b1fe7a97aa82411b26950d9f /security/openssl-beta
parenta8b306026ae734dbaf1895b82723d63263c72453 (diff)
downloadports-65e2b09e203793a4b84951b457e7e73247c06db1.tar.gz
ports-65e2b09e203793a4b84951b457e7e73247c06db1.zip
Notes
Diffstat (limited to 'security/openssl-beta')
-rw-r--r--security/openssl-beta/Makefile.ssl56
1 files changed, 56 insertions, 0 deletions
diff --git a/security/openssl-beta/Makefile.ssl b/security/openssl-beta/Makefile.ssl
new file mode 100644
index 000000000000..265c96da3b47
--- /dev/null
+++ b/security/openssl-beta/Makefile.ssl
@@ -0,0 +1,56 @@
+# makefile for use of: OpenSSH
+# Date created: 31 May 2002
+# Whom: dinoex
+#
+# $FreeBSD$
+#
+
+.if defined(USE_OPENSSL_BASE)
+OPENSSLBASE= /usr
+OPENSSLDIR= /etc/ssl
+
+.if !exists(/usr/lib/libcrypto.so)
+.BEGIN:
+ @${ECHO_CMD} "This port requires the OpenSSL library, which is part of"
+ @${ECHO_CMD} "the FreeBSD crypto distribution but not installed on your"
+ @${ECHO_CMD} "machine. Please see the \"OpenSSL\" section in the handbook"
+ @${ECHO_CMD} "(at \"http://www.FreeBSD.org/handbook/openssl.html\", for instance)"
+ @${ECHO_CMD} "for instructions on how to obtain and install the FreeBSD"
+ @${ECHO_CMD} "OpenSSL distribution."
+ @${FALSE}
+.endif
+
+# OpenSSL in the base system may not include IDEA for patent licensing reasons.
+.if defined(MAKE_IDEA) && !defined(OPENSSL_IDEA)
+OPENSSL_IDEA= ${MAKE_IDEA}
+.else
+OPENSSL_IDEA?= NO
+.endif
+
+.if ${OPENSSL_IDEA} == "NO"
+# XXX This is a hack to work around the fact that /etc/make.conf clobbers
+# our CFLAGS. It might not be enough for all future ports.
+.if defined(HAS_CONFIGURE)
+CFLAGS+= -DNO_IDEA
+.else
+OPENSSL_CFLAGS+= -DNO_IDEA
+.endif
+MAKE_ARGS+= OPENSSL_CFLAGS="${OPENSSL_CFLAGS}"
+.endif
+
+.else
+
+OPENSSLBASE= ${LOCALBASE}
+OPENSSLDIR= ${OPENSSLBASE}/openssl
+LIB_DEPENDS+= crypto.3:${PORTSDIR}/security/openssl
+
+.endif
+
+OPENSSLLIB= ${OPENSSLBASE}/lib
+OPENSSLINC= ${OPENSSLBASE}/include
+MAKE_ENV+= OPENSSLLIB=${OPENSSLLIB} OPENSSLINC=${OPENSSLINC} \
+ OPENSSLBASE=${OPENSSLBASE} OPENSSLDIR=${OPENSSLDIR}
+
+### crypto
+#RESTRICTED= "Contains cryptography."
+