aboutsummaryrefslogtreecommitdiff
path: root/security/openssl-beta
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2002-05-13 18:54:03 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2002-05-13 18:54:03 +0000
commit227e98a41314356b5a5b746b0e90287ba695222e (patch)
tree2214a33dc80c5b12f95c56ff4321908a16b0e030 /security/openssl-beta
parented2e2d6174b478314ef2705d57acc868d401525d (diff)
downloadports-227e98a41314356b5a5b746b0e90287ba695222e.tar.gz
ports-227e98a41314356b5a5b746b0e90287ba695222e.zip
Notes
Diffstat (limited to 'security/openssl-beta')
-rw-r--r--security/openssl-beta/Makefile10
-rw-r--r--security/openssl-beta/distinfo2
-rw-r--r--security/openssl-beta/files/patch-ac21
3 files changed, 18 insertions, 15 deletions
diff --git a/security/openssl-beta/Makefile b/security/openssl-beta/Makefile
index f52553f235d9..8b44bec37c00 100644
--- a/security/openssl-beta/Makefile
+++ b/security/openssl-beta/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= openssl
-PORTVERSION= 0.9.6c
-PORTREVISION= 1
+PORTVERSION= 0.9.6d
CATEGORIES= security devel
MASTER_SITES= http://www.openssl.org/source/ \
ftp://ftp.openssl.org/source/ \
@@ -87,6 +86,7 @@ MAN3= BN_CTX_new.3 BN_CTX_start.3 BN_add.3 BN_add_word.3 \
SSL_CTX_sess_set_get_cb.3 SSL_CTX_sessions.3 \
SSL_CTX_set_cert_store.3 SSL_CTX_set_cert_verify_callback.3 \
SSL_CTX_set_cipher_list.3 SSL_CTX_set_client_CA_list.3 \
+ SSL_CTX_set_client_cert_cb.3 \
SSL_CTX_set_default_passwd_cb.3 SSL_CTX_set_info_callback.3 \
SSL_CTX_set_mode.3 SSL_CTX_set_options.3 \
SSL_CTX_set_quiet_shutdown.3 SSL_CTX_set_session_cache_mode.3 \
@@ -113,11 +113,15 @@ MAN5= config.5
MAN7= des_modes.7
+.if defined(BATCH) || defined(OPENSSL_WITH_386)
+EXTRACONFIGURE= 386
+.endif
+
do-configure:
@cd ${WRKSRC} \
&& ${SETENV} CC="${CC}" CFLAGS="${CFLAGS}" PERL="${PERL}" \
./config --prefix=${PREFIX} --openssldir=${PREFIX}/openssl \
- -L${PREFIX}/lib
+ -L${PREFIX}/lib ${EXTRACONFIGURE}
post-install:
.if !defined(NOSHARED)
diff --git a/security/openssl-beta/distinfo b/security/openssl-beta/distinfo
index 957406c80cef..cdd7f2e47220 100644
--- a/security/openssl-beta/distinfo
+++ b/security/openssl-beta/distinfo
@@ -1 +1 @@
-MD5 (openssl-0.9.6c.tar.gz) = 6d0a279079fae4f0a5a7af60c89ea178
+MD5 (openssl-0.9.6d.tar.gz) = 6cba586958f6e35f28dde70bd9e5d10a
diff --git a/security/openssl-beta/files/patch-ac b/security/openssl-beta/files/patch-ac
index 0fd4e9125c5c..8c390d4186a3 100644
--- a/security/openssl-beta/files/patch-ac
+++ b/security/openssl-beta/files/patch-ac
@@ -1,23 +1,22 @@
---- Configure.orig Thu Dec 6 14:11:39 2001
-+++ Configure Sat Apr 20 16:30:42 2002
-@@ -303,7 +303,7 @@
+--- Configure.orig Fri May 10 01:05:49 2002
++++ Configure Fri May 10 19:00:05 2002
+@@ -309,7 +309,7 @@
#
# This probably belongs in a different section.
#
--"FreeBSD-alpha","gcc:-DTERMIOS -O -fomit-frame-pointer::(unknown)::SIXTY_FOUR_BIT_LONG RC4_CHUNK DES_INT DES_PTR DES_RISC2::::::::::dlfcn:bsd-gcc-shared:-fPIC:.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
+-"FreeBSD-alpha","gcc:-DTERMIOS -O -fomit-frame-pointer::(unknown)::SIXTY_FOUR_BIT_LONG RC4_CHUNK DES_INT DES_PTR DES_RISC2::::::::::dlfcn:bsd-gcc-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
+"FreeBSD-alpha","$ENV{CC}:-DTERMIOS $ENV{CFLAGS}::(unknown)::SIXTY_FOUR_BIT_LONG RC4_CHUNK DES_INT DES_PTR DES_RISC2:::",
#### Alpha Linux with GNU C and Compaq C setups
# Special notes:
-@@ -341,8 +341,9 @@
- "NetBSD-sparc", "gcc:-DTERMIOS -O3 -fomit-frame-pointer -mv8 -Wall -DB_ENDIAN::(unknown)::BN_LLONG MD2_CHAR RC4_INDEX DES_UNROLL::::::::::dlfcn:bsd-gcc-shared:-fPIC:.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
- "NetBSD-m68", "gcc:-DTERMIOS -O3 -fomit-frame-pointer -Wall -DB_ENDIAN::(unknown)::BN_LLONG MD2_CHAR RC4_INDEX DES_UNROLL::::::::::dlfcn:bsd-gcc-shared:-fPIC:.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
- "NetBSD-x86", "gcc:-DTERMIOS -O3 -fomit-frame-pointer -m486 -Wall::(unknown)::BN_LLONG ${x86_gcc_des} ${x86_gcc_opts}::::::::::dlfcn:bsd-gcc-shared:-fPIC:.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
--"FreeBSD-elf", "gcc:-DTERMIOS -DL_ENDIAN -fomit-frame-pointer -O3 -m486 -Wall::-pthread -D_REENTRANT -D_THREAD_SAFE -D_THREADSAFE::BN_LLONG ${x86_gcc_des} ${x86_gcc_opts}:${x86_elf_asm}:dlfcn:bsd-gcc-shared:-fPIC:.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
+@@ -348,8 +348,8 @@
+ "NetBSD-sparc", "gcc:-DTERMIOS -O3 -fomit-frame-pointer -mv8 -Wall -DB_ENDIAN::(unknown)::BN_LLONG MD2_CHAR RC4_INDEX DES_UNROLL::::::::::dlfcn:bsd-gcc-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
+ "NetBSD-m68", "gcc:-DTERMIOS -O3 -fomit-frame-pointer -Wall -DB_ENDIAN::(unknown)::BN_LLONG MD2_CHAR RC4_INDEX DES_UNROLL::::::::::dlfcn:bsd-gcc-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
+ "NetBSD-x86", "gcc:-DTERMIOS -O3 -fomit-frame-pointer -m486 -Wall::(unknown)::BN_LLONG ${x86_gcc_des} ${x86_gcc_opts}::::::::::dlfcn:bsd-gcc-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
+-"FreeBSD-elf", "gcc:-DTERMIOS -DL_ENDIAN -fomit-frame-pointer -O3 -m486 -Wall::-pthread -D_REENTRANT -D_THREAD_SAFE -D_THREADSAFE::BN_LLONG ${x86_gcc_des} ${x86_gcc_opts}:${x86_elf_asm}:dlfcn:bsd-gcc-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
-"FreeBSD", "gcc:-DTERMIOS -DL_ENDIAN -fomit-frame-pointer -O3 -m486 -Wall::(unknown)::BN_LLONG ${x86_gcc_des} ${x86_gcc_opts}:${x86_out_asm}",
+"FreeBSD-elf", "$ENV{CC}:-DTERMIOS -DL_ENDIAN $ENV{CFLAGS}::(unknown)::BN_LLONG ${x86_gcc_des} ${x86_gcc_opts}:${x86_elf_asm}",
+"FreeBSD", "$ENV{CC}:-DTERMIOS -DL_ENDIAN $ENV{CFLAGS}::(unknown)::BN_LLONG ${x86_gcc_des} ${x86_gcc_opts}:${x86_out_asm}",
-+
"bsdi-gcc", "gcc:-O3 -ffast-math -DL_ENDIAN -DPERL5 -m486::(unknown)::RSA_LLONG ${x86_gcc_des} ${x86_gcc_opts}:${x86_bsdi_asm}",
- "bsdi-elf-gcc", "gcc:-DPERL5 -DL_ENDIAN -fomit-frame-pointer -O3 -m486 -Wall::(unknown):-ldl:BN_LLONG ${x86_gcc_des} ${x86_gcc_opts}:${x86_elf_asm}:dlfcn:bsd-gcc-shared:-fPIC:.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
+ "bsdi-elf-gcc", "gcc:-DPERL5 -DL_ENDIAN -fomit-frame-pointer -O3 -m486 -Wall::(unknown):-ldl:BN_LLONG ${x86_gcc_des} ${x86_gcc_opts}:${x86_elf_asm}:dlfcn:bsd-gcc-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
"nextstep", "cc:-O -Wall:<libc.h>:(unknown)::BN_LLONG ${x86_gcc_des} ${x86_gcc_opts}:::",