aboutsummaryrefslogtreecommitdiff
path: root/security/openssl/Makefile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2014-07-03 16:49:37 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2014-07-03 16:49:37 +0000
commit0622b71a49844a589d52af49c4bdfc23f415b506 (patch)
tree9a169795a576cc25939a50822cf2671948a51d75 /security/openssl/Makefile
parent2e7edc1c924146234413b8a6ce40b4aeae863576 (diff)
downloadports-0622b71a49844a589d52af49c4bdfc23f415b506.tar.gz
ports-0622b71a49844a589d52af49c4bdfc23f415b506.zip
Notes
Diffstat (limited to 'security/openssl/Makefile')
-rw-r--r--security/openssl/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index 4b620d8e7f8d..702a8adb6977 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -56,7 +56,6 @@ USE_PERL5= build
MAKE_ARGS+= WHOLE_ARCHIVE_FLAG=--whole-archive
MAKE_ENV+= LIBRPATH="${PREFIX}/lib" GREP_OPTIONS=
SUB_FILES= pkg-message
-OPENSSLDIR= ${PREFIX}/openssl
FIX_POD=apps/cms.pod \
apps/smime.pod \
@@ -84,6 +83,9 @@ FIX_POD=apps/cms.pod \
IGNORE= OpenSSL can not be installed over the base version
.endif
+OPENSSLDIR?= ${PREFIX}/openssl
+PLIST_SUB+= OPENSSLDIR=${OPENSSLDIR:S=^${PREFIX}/==}
+
OPENSSL_BASE_SONAME!= readlink ${DESTDIR}/usr/lib/libcrypto.so || true
OPENSSL_SHLIBVER_BASE= ${OPENSSL_BASE_SONAME:E}
OPENSSL_BASE_SOPATH= ${OPENSSL_BASE_SONAME:H}