aboutsummaryrefslogtreecommitdiff
path: root/security/openssl/Makefile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2002-05-13 18:54:03 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2002-05-13 18:54:03 +0000
commit227e98a41314356b5a5b746b0e90287ba695222e (patch)
tree2214a33dc80c5b12f95c56ff4321908a16b0e030 /security/openssl/Makefile
parented2e2d6174b478314ef2705d57acc868d401525d (diff)
downloadports-227e98a41314356b5a5b746b0e90287ba695222e.tar.gz
ports-227e98a41314356b5a5b746b0e90287ba695222e.zip
Notes
Diffstat (limited to 'security/openssl/Makefile')
-rw-r--r--security/openssl/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index f52553f235d9..8b44bec37c00 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= openssl
-PORTVERSION= 0.9.6c
-PORTREVISION= 1
+PORTVERSION= 0.9.6d
CATEGORIES= security devel
MASTER_SITES= http://www.openssl.org/source/ \
ftp://ftp.openssl.org/source/ \
@@ -87,6 +86,7 @@ MAN3= BN_CTX_new.3 BN_CTX_start.3 BN_add.3 BN_add_word.3 \
SSL_CTX_sess_set_get_cb.3 SSL_CTX_sessions.3 \
SSL_CTX_set_cert_store.3 SSL_CTX_set_cert_verify_callback.3 \
SSL_CTX_set_cipher_list.3 SSL_CTX_set_client_CA_list.3 \
+ SSL_CTX_set_client_cert_cb.3 \
SSL_CTX_set_default_passwd_cb.3 SSL_CTX_set_info_callback.3 \
SSL_CTX_set_mode.3 SSL_CTX_set_options.3 \
SSL_CTX_set_quiet_shutdown.3 SSL_CTX_set_session_cache_mode.3 \
@@ -113,11 +113,15 @@ MAN5= config.5
MAN7= des_modes.7
+.if defined(BATCH) || defined(OPENSSL_WITH_386)
+EXTRACONFIGURE= 386
+.endif
+
do-configure:
@cd ${WRKSRC} \
&& ${SETENV} CC="${CC}" CFLAGS="${CFLAGS}" PERL="${PERL}" \
./config --prefix=${PREFIX} --openssldir=${PREFIX}/openssl \
- -L${PREFIX}/lib
+ -L${PREFIX}/lib ${EXTRACONFIGURE}
post-install:
.if !defined(NOSHARED)