aboutsummaryrefslogtreecommitdiff
path: root/security/openssl/Makefile
diff options
context:
space:
mode:
authorDirk Froemberg <dirk@FreeBSD.org>1999-11-07 22:19:49 +0000
committerDirk Froemberg <dirk@FreeBSD.org>1999-11-07 22:19:49 +0000
commitbd8d8600c4cd2d871aaa0a5244d266c861f4a285 (patch)
tree1e0a65e32b823dc214474e61878e537e03bf7412 /security/openssl/Makefile
parente1b96c431c627112c996f7c95d27deeb43ebe1f6 (diff)
downloadports-bd8d8600c4cd2d871aaa0a5244d266c861f4a285.tar.gz
ports-bd8d8600c4cd2d871aaa0a5244d266c861f4a285.zip
Notes
Diffstat (limited to 'security/openssl/Makefile')
-rw-r--r--security/openssl/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index 1c5467983ce6..ec5835514d83 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -7,7 +7,7 @@
#
DISTNAME= openssl-0.9.4
-CATEGORIES= security devel
+CATEGORIES= security devel
MASTER_SITES= http://www.openssl.org/source/ \
ftp://ftp.openssl.org/source/ \
ftp://ftp.sunet.se/pub/security/tools/net/openssl/source/ \
@@ -17,6 +17,9 @@ MAINTAINER= dirk@FreeBSD.org
RESTRICTED= "Cryptography"
USE_PERL5= yes
+ALL_TARGET= freebsd-shared all
+SHLIBVER= 1
+MAKE_ENV+= SHLIBVER=${SHLIBVER}
.if !defined(USA_RESIDENT) || ${USA_RESIDENT} != YES && ${USA_RESIDENT} != NO
pre-fetch:
@@ -39,6 +42,11 @@ do-configure:
${RSAREF} -L${PREFIX}/lib
post-install:
+.for i in libcrypto libssl
+ @${INSTALL_DATA} ${WRKSRC}/$i.so.${SHLIBVER} ${PREFIX}/lib
+ @${LN} -s $i.so.${SHLIBVER} ${PREFIX}/lib/$i.so
+.endfor
+ @${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
.if !defined(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/openssl
@${INSTALL_DATA} ${WRKSRC}/doc/* ${PREFIX}/share/doc/openssl