aboutsummaryrefslogtreecommitdiff
path: root/security/openssl/Makefile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2003-04-07 05:50:39 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2003-04-07 05:50:39 +0000
commit605d36542bb051e15b258264bc1c2c7478ba2caf (patch)
tree605c47f18972038f9f7ac6af62dac361b028169d /security/openssl/Makefile
parente541bd8eee32a447faddbda35d0692954bc51ffe (diff)
Notes
Diffstat (limited to 'security/openssl/Makefile')
-rw-r--r--security/openssl/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index febd8509f07e..c520d02657c4 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -828,10 +828,10 @@ PLIST_SUB+= SHARED="@comment "
.else
PLIST_SUB+= SHARED=""
ALL_TARGET= freebsd-shared all
-.if exists(/usr/lib/libcrypto.so.3)
-SHLIBVER= 4
-.else
+.if exists(/usr/lib/libcrypto.so.2) && !exists(/usr/lib/libcrypto.so.3)
SHLIBVER= 3
+.else
+SHLIBVER= 4
.endif
MAKE_ENV+= SHLIBVER=${SHLIBVER}
PLIST_SUB+= SHLIBVER=${SHLIBVER}
@@ -841,10 +841,10 @@ INSTALLS_SHLIB= yes
.if defined(OPENSSL_OVERWRITE_BASE)
PKGNAMESUFFIX= -overwrite-base
PREFIX= /usr
-.if exists(/usr/lib/libcrypto.so.3)
-SHLIBVER= 3
-.else
+.if exists(/usr/lib/libcrypto.so.2) && !exists(/usr/lib/libcrypto.so.3)
SHLIBVER= 2
+.else
+SHLIBVER= 3
.endif
OPENSSLDIR= /etc/ssl
MANPREFIX= ${PREFIX}/openssl