aboutsummaryrefslogtreecommitdiff
path: root/security/openssl
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2005-01-24 13:56:35 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2005-01-24 13:56:35 +0000
commitf3d9a33c70e042020439ff1ead1724636eb4d8da (patch)
treec2c777a980f1b1223295a6c320465062e9b70475 /security/openssl
parent5fea3855b1b9761332228728d1aa6211cf5485d1 (diff)
downloadports-f3d9a33c70e042020439ff1ead1724636eb4d8da.tar.gz
ports-f3d9a33c70e042020439ff1ead1724636eb4d8da.zip
Notes
Diffstat (limited to 'security/openssl')
-rw-r--r--security/openssl/Makefile2
-rw-r--r--security/openssl/files/patch-hw_cryptodev.c-cloning37
2 files changed, 38 insertions, 1 deletions
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index 33cbe3707703..678cfadcaaa0 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -11,7 +11,7 @@ PORTVERSION= 0.9.7
PORTREVISION!= date -v-1d +%Y%m%d
.else
PORTVERSION= 0.9.7e
-PORTREVISION?= 1
+PORTREVISION?= 2
.endif
CATEGORIES= security devel
MASTER_SITES= http://www.openssl.org/%SUBDIR%/ \
diff --git a/security/openssl/files/patch-hw_cryptodev.c-cloning b/security/openssl/files/patch-hw_cryptodev.c-cloning
new file mode 100644
index 000000000000..82c159a32528
--- /dev/null
+++ b/security/openssl/files/patch-hw_cryptodev.c-cloning
@@ -0,0 +1,37 @@
+Index: crypto/engine/hw_cryptodev.c
+===================================================================
+RCS file: /home/ncvs/src/crypto/openssl/crypto/engine/hw_cryptodev.c,v
+retrieving revision 1.1.1.3
+diff -u -r1.1.1.3 hw_cryptodev.c
+--- crypto/engine/hw_cryptodev.c 17 Mar 2004 15:44:46 -0000 1.1.1.3
++++ crypto/engine/hw_cryptodev.c 18 Jan 2005 12:27:17 -0000
+@@ -180,6 +180,10 @@
+ return (-1);
+ if (ioctl(fd, CRIOGET, &retfd) == -1)
+ return (-1);
++ if (retfd == -1)
++ retfd = fd;
++ else
++ close(fd);
+
+ /* close on exec */
+ if (fcntl(retfd, F_SETFD, 1) == -1) {
+Index: crypto/evp/openbsd_hw.c
+===================================================================
+RCS file: /home/ncvs/src/crypto/openssl/crypto/evp/openbsd_hw.c,v
+retrieving revision 1.1.1.1
+diff -u -r1.1.1.1 openbsd_hw.c
+--- crypto/evp/openbsd_hw.c 28 Jan 2003 21:24:39 -0000 1.1.1.1
++++ crypto/evp/openbsd_hw.c 18 Jan 2005 12:26:45 -0000
+@@ -109,7 +109,10 @@
+ dev_failed=1;
+ return 0;
+ }
+- close(cryptodev_fd);
++ if (fd == -1)
++ fd = cryptodev_fd;
++ else
++ close(cryptodev_fd);
+ }
+ assert(ses);
+ memset(ses,'\0',sizeof *ses);