aboutsummaryrefslogtreecommitdiff
path: root/security/openssl
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2010-04-06 19:16:05 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2010-04-06 19:16:05 +0000
commitadab779a7cd8ae58f367709cafb96e6aab0e5078 (patch)
tree68b13ede54564a7543de7c86af3c3ebe86ba8b1d /security/openssl
parentbc6a25167b54ffd3cc90b667cd009ffbbb7b2a40 (diff)
downloadports-adab779a7cd8ae58f367709cafb96e6aab0e5078.tar.gz
ports-adab779a7cd8ae58f367709cafb96e6aab0e5078.zip
Notes
Diffstat (limited to 'security/openssl')
-rw-r--r--security/openssl/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index a25a5596f141..088801b4f59d 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -28,6 +28,7 @@ BUILD_DEPENDS= makedepend:${PORTSDIR}/devel/makedepend
OPTIONS= I386 "Use optimized assembler for 80386" off \
SSE2 "Use runtime SSE2 detection" on \
+ ASM "Build with optimized Assembler" on \
ZLIB "Build with zlib compression" on \
MD2 "Build with MD2 hash (obsolete)" off \
RC5 "Build with RC5 chipher (patented)" off \
@@ -1054,6 +1055,12 @@ EXTRACONFIGURE+= 386
EXTRACONFIGURE+= no-sse2
.endif
+.if !defined(WITHOUT_ASM)
+EXTRACONFIGURE+= enable-asm
+.else
+EXTRACONFIGURE+= no-asm
+.endif
+
.if defined(NOSHARED)
PLIST_SUB+= SHARED="@comment "
.else