aboutsummaryrefslogtreecommitdiff
path: root/security/openssl
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-07-29 08:36:47 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-07-29 08:36:47 +0000
commit8d3ad27fde4872fd14b8a2e7e59457a18bb9c35f (patch)
tree062c29afeb589c4d284bb5e1631ea6544a6a84b8 /security/openssl
parent6c1bc50c5abdca1badf06c2ce824c7d18348f62e (diff)
Notes
Diffstat (limited to 'security/openssl')
-rw-r--r--security/openssl/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index 23f7972ac473..f163e4a9f804 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -1066,6 +1066,12 @@ EXTRACONFIGURE+= enable-asm
EXTRACONFIGURE+= no-asm
.endif
+.if ${PORT_OPTIONS:MTHREADS}
+EXTRACONFIGURE+= threads
+.else
+EXTRACONFIGURE+= no-threads
+.endif
+
.if ${PORT_OPTIONS:MSHARED}
PLIST_SUB+= SHARED=""
EXTRACONFIGURE+= shared
@@ -1146,7 +1152,6 @@ post-patch:
do-configure:
@${REINPLACE_CMD} -e "s|options 386|options|" \
${WRKSRC}/config
-
.if ${PORT_OPTIONS:MTHREADS}
cd ${WRKSRC} \
&& ${SETENV} CC="${CC}" FREEBSDCC="${CC}" CFLAGS="${CFLAGS}" PERL="${PERL}" \