aboutsummaryrefslogtreecommitdiff
path: root/security/openssl
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2009-03-28 17:32:24 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2009-03-28 17:32:24 +0000
commit06e7a37f0ab116c54c4194f2b9de28079a3450a1 (patch)
tree515d516be7c47b7e752fa1cfcf68a24365b83d62 /security/openssl
parentba4d5fa369028d4738b9692fc5a9444bb9e3e496 (diff)
downloadports-06e7a37f0ab116c54c4194f2b9de28079a3450a1.tar.gz
ports-06e7a37f0ab116c54c4194f2b9de28079a3450a1.zip
Notes
Diffstat (limited to 'security/openssl')
-rw-r--r--security/openssl/Makefile3
-rw-r--r--security/openssl/distinfo6
-rw-r--r--security/openssl/files/patch-enc_min.c11
3 files changed, 4 insertions, 16 deletions
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index 9344e878e5fc..f2730ad6b0d0 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= openssl
-PORTVERSION= 0.9.8j
-PORTREVISION= 1
+PORTVERSION= 0.9.8k
CATEGORIES= security devel
MASTER_SITES= http://www.openssl.org/%SUBDIR%/ \
ftp://ftp.openssl.org/%SUBDIR%/ \
diff --git a/security/openssl/distinfo b/security/openssl/distinfo
index 625d8f08c875..7e1cd3e7b8a2 100644
--- a/security/openssl/distinfo
+++ b/security/openssl/distinfo
@@ -1,3 +1,3 @@
-MD5 (openssl-0.9.8j.tar.gz) = a5cb5f6c3d11affb387ecf7a997cac0c
-SHA256 (openssl-0.9.8j.tar.gz) = 7131242042dbd631fbd83436f42aea1775e7c32f587fa4ada5a01df4c3ae8e8b
-SIZE (openssl-0.9.8j.tar.gz) = 3738359
+MD5 (openssl-0.9.8k.tar.gz) = e555c6d58d276aec7fdc53363e338ab3
+SHA256 (openssl-0.9.8k.tar.gz) = 7e7cd4f3974199b729e6e3a0af08bd4279fde0370a1120c1a3b351ab090c6101
+SIZE (openssl-0.9.8k.tar.gz) = 3852259
diff --git a/security/openssl/files/patch-enc_min.c b/security/openssl/files/patch-enc_min.c
deleted file mode 100644
index 7d4af5ac3de9..000000000000
--- a/security/openssl/files/patch-enc_min.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- crypto/evp/enc_min.c.orig 2008-12-02 19:14:44.000000000 +0100
-+++ crypto/evp/enc_min.c 2009-01-09 18:20:35.000000000 +0100
-@@ -199,7 +199,7 @@
- enc = 1;
- ctx->encrypt = enc;
- }
--#ifdef OPENSSL_NO_FIPS
-+#ifndef OPENSSL_NO_FIPS
- if(FIPS_selftest_failed())
- {
- FIPSerr(FIPS_F_EVP_CIPHERINIT_EX,FIPS_R_FIPS_SELFTEST_FAILED);