aboutsummaryrefslogtreecommitdiff
path: root/security/openssl
diff options
context:
space:
mode:
authorBernard Spil <brnrd@FreeBSD.org>2021-08-24 15:16:35 +0000
committerBernard Spil <brnrd@FreeBSD.org>2021-08-24 17:54:49 +0000
commitd3011e20b1f199d4ca63d783274387f35a0afefa (patch)
treeb0550c61a8640ba15966c56dcaf9fa88275a3c8d /security/openssl
parent2a62b7ca948a3a92942194348f94210fb5c3f889 (diff)
downloadports-d3011e20b1f199d4ca63d783274387f35a0afefa.tar.gz
ports-d3011e20b1f199d4ca63d783274387f35a0afefa.zip
Diffstat (limited to 'security/openssl')
-rw-r--r--security/openssl/Makefile3
-rw-r--r--security/openssl/distinfo6
-rw-r--r--security/openssl/files/extra-patch-ktls3
-rw-r--r--security/openssl/pkg-plist1
4 files changed, 7 insertions, 6 deletions
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index ec3e8a967d0f..d97a9cc929d3 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -1,8 +1,7 @@
# Created by: Dirk Froemberg <dirk@FreeBSD.org>
PORTNAME= openssl
-PORTVERSION= 1.1.1k
-PORTREVISION= 2
+PORTVERSION= 1.1.1l
PORTEPOCH= 1
CATEGORIES= security devel
MASTER_SITES= https://www.openssl.org/source/ \
diff --git a/security/openssl/distinfo b/security/openssl/distinfo
index 181ff679f5fb..ea60c25fc735 100644
--- a/security/openssl/distinfo
+++ b/security/openssl/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1616688925
-SHA256 (openssl-1.1.1k.tar.gz) = 892a0875b9872acd04a9fde79b1f943075d5ea162415de3047c327df33fbaee5
-SIZE (openssl-1.1.1k.tar.gz) = 9823400
+TIMESTAMP = 1629816807
+SHA256 (openssl-1.1.1l.tar.gz) = 0b7a3e5e59c34827fe0c3a74b7ec8baef302b98fa80088d7f9153aa16fa76bd1
+SIZE (openssl-1.1.1l.tar.gz) = 9834044
diff --git a/security/openssl/files/extra-patch-ktls b/security/openssl/files/extra-patch-ktls
index ce1f6242fd58..7258df22abee 100644
--- a/security/openssl/files/extra-patch-ktls
+++ b/security/openssl/files/extra-patch-ktls
@@ -2573,11 +2573,12 @@ index 4a27ee1ba2..1388219551 100644
#include <string.h>
#include <openssl/opensslconf.h>
-@@ -17,11 +18,13 @@
+@@ -17,12 +18,14 @@
#include <openssl/srp.h>
#include <openssl/txt_db.h>
#include <openssl/aes.h>
+#include <openssl/rand.h>
+ #include <openssl/x509v3.h>
#include "ssltestlib.h"
#include "testutil.h"
diff --git a/security/openssl/pkg-plist b/security/openssl/pkg-plist
index c442ee16969d..dd4e70280d25 100644
--- a/security/openssl/pkg-plist
+++ b/security/openssl/pkg-plist
@@ -583,6 +583,7 @@ man/man1/x509.1.gz
%%MAN3%%man/man3/BN_RECP_CTX_free.3.gz
%%MAN3%%man/man3/BN_RECP_CTX_new.3.gz
%%MAN3%%man/man3/BN_RECP_CTX_set.3.gz
+%%MAN3%%man/man3/BN_abs_is_word.3.gz
%%MAN3%%man/man3/BN_add.3.gz
%%MAN3%%man/man3/BN_add_word.3.gz
%%MAN3%%man/man3/BN_bin2bn.3.gz