aboutsummaryrefslogtreecommitdiff
path: root/security/openssl
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2009-09-19 05:21:20 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2009-09-19 05:21:20 +0000
commit113bb2e0b78f943128b4267fe9cdc7972537f3ca (patch)
treeab8b2296f876d0cf468a160705d267136e9962a9 /security/openssl
parentc31ab796066436fae2d28d254b6fce196fc9bc6a (diff)
downloadports-113bb2e0b78f943128b4267fe9cdc7972537f3ca.tar.gz
ports-113bb2e0b78f943128b4267fe9cdc7972537f3ca.zip
Notes
Diffstat (limited to 'security/openssl')
-rw-r--r--security/openssl/Makefile2
-rw-r--r--security/openssl/files/patch-eng_cryptodev.c4
2 files changed, 3 insertions, 3 deletions
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index 0a788dd403fa..1dca1caac600 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -7,7 +7,7 @@
PORTNAME= openssl
PORTVERSION= 0.9.8k
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= security devel
MASTER_SITES= http://www.openssl.org/%SUBDIR%/ \
ftp://ftp.openssl.org/%SUBDIR%/ \
diff --git a/security/openssl/files/patch-eng_cryptodev.c b/security/openssl/files/patch-eng_cryptodev.c
index 8b8942c098ff..b8e146cc58be 100644
--- a/security/openssl/files/patch-eng_cryptodev.c
+++ b/security/openssl/files/patch-eng_cryptodev.c
@@ -57,8 +57,8 @@
return (-1);
+ if (retfd == -1)
+ retfd = fd;
-+ else
-+/* close(fd); fix for PR=138881 */
++/* else fix for PR=138881 */
++/* close(fd); fix for PR=138881 */
/* close on exec */
if (fcntl(retfd, F_SETFD, 1) == -1) {