aboutsummaryrefslogtreecommitdiff
path: root/security/openssl
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2003-01-31 19:54:56 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2003-01-31 19:54:56 +0000
commit4686c6597f640d413387a85b15714654c03fc9fb (patch)
treeebbd67f40b2f89a7ab1d69c521e0a980e6cf111a /security/openssl
parent6b5fdc3e6390d24294c5aed2e010434590bdf273 (diff)
downloadports-4686c6597f640d413387a85b15714654c03fc9fb.tar.gz
ports-4686c6597f640d413387a85b15714654c03fc9fb.zip
Notes
Diffstat (limited to 'security/openssl')
-rw-r--r--security/openssl/Makefile5
-rw-r--r--security/openssl/Makefile.ssl10
2 files changed, 13 insertions, 2 deletions
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index bd32e14f5202..d1c08533b55f 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -7,6 +7,7 @@
PORTNAME= openssl
PORTVERSION= 0.9.7
+PORTREVISION= 1
CATEGORIES= security devel
MASTER_SITES= http://www.openssl.org/source/ \
ftp://ftp.openssl.org/source/ \
@@ -33,7 +34,11 @@ PLIST_SUB+= SHARED="@comment "
.else
PLIST_SUB+= SHARED=""
ALL_TARGET= freebsd-shared all
+.if exists(/usr/lib/libcrypto.so.3)
+SHLIBVER= 4
+.else
SHLIBVER= 3
+.endif
MAKE_ENV+= SHLIBVER=${SHLIBVER}
PLIST_SUB+= SHLIBVER=${SHLIBVER}
INSTALLS_SHLIB= yes
diff --git a/security/openssl/Makefile.ssl b/security/openssl/Makefile.ssl
index fa775e034068..11d7db7fc28f 100644
--- a/security/openssl/Makefile.ssl
+++ b/security/openssl/Makefile.ssl
@@ -48,13 +48,19 @@ MAKE_ARGS+= OPENSSL_CFLAGS="${OPENSSL_CFLAGS}"
.else
+.if exists(/usr/lib/libcrypto.so.3)
+SHLIBVER= 4
+.else
+SHLIBVER= 3
+.endif
+
OPENSSLBASE= ${LOCALBASE}
.if defined(USE_OPENSSL_BETA)
OPENSSLDIR= ${OPENSSLBASE}/openssl
-LIB_DEPENDS+= crypto.3:${PORTSDIR}/security/openssl-beta
+LIB_DEPENDS+= crypto.${SHLIBVER}:${PORTSDIR}/security/openssl-beta
.else
OPENSSLDIR= ${OPENSSLBASE}/openssl
-LIB_DEPENDS+= crypto.3:${PORTSDIR}/security/openssl
+LIB_DEPENDS+= crypto.${SHLIBVER}:${PORTSDIR}/security/openssl
.endif
.endif