aboutsummaryrefslogtreecommitdiff
path: root/security/openssl_tpm_engine/Makefile
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2019-03-02 23:48:27 +0000
committerHiroki Sato <hrs@FreeBSD.org>2019-03-02 23:48:27 +0000
commit20234d00b9249d1098f00d768e2b52e117ad6a74 (patch)
tree236c673e42bddead006ad410a87b5aa7d60072bb /security/openssl_tpm_engine/Makefile
parent840f456a200cc97961c7490cbe4a4caa9186921a (diff)
Notes
Diffstat (limited to 'security/openssl_tpm_engine/Makefile')
-rw-r--r--security/openssl_tpm_engine/Makefile22
1 files changed, 11 insertions, 11 deletions
diff --git a/security/openssl_tpm_engine/Makefile b/security/openssl_tpm_engine/Makefile
index 68dec8555074..b7553b4e6fb5 100644
--- a/security/openssl_tpm_engine/Makefile
+++ b/security/openssl_tpm_engine/Makefile
@@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= openssl_tpm_engine
-PORTVERSION= 0.4.2
-PORTREVISION= 4
+PORTVERSION= 0.5.0
+DISTVERSIONPREFIX= v
CATEGORIES= security
-MASTER_SITES= SF/trousers/OpenSSL%20TPM%20Engine/${PORTVERSION}
MAINTAINER= hrs@FreeBSD.org
COMMENT= OpenSSL TPM engine
@@ -16,16 +15,16 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${LOCALBASE}/sbin/tcsd:security/trousers
LIB_DEPENDS= libtspi.so:security/trousers
-USES= autoreconf gmake libtool ssl
+USES= autoreconf gmake libtool localbase ssl
+USE_GITHUB= yes
USE_LDCONFIG= yes
+
+GH_ACCOUNT= mgerstner
GNU_CONFIGURE= yes
-LDFLAGS+= -L${OPENSSLLIB} -lcrypto -L${LOCALBASE}/lib
-CFLAGS+= -I${OPENSSLINC} -I${LOCALBASE}/include
+CONFIGURE_ARGS= --with-openssl="${OPENSSLBASE}"
SUB_FILES= pkg-message
PLIST_FILES= bin/create_tpm_key \
- lib/openssl/engines/libtpm.so \
- lib/openssl/engines/libtpm.so.0 \
- lib/openssl/engines/libtpm.so.0.0.0
+ lib/openssl/engines/tpm.so
INSTALL_TARGET= install-strip
PORTEXAMPLES= openssl.cnf.sample
@@ -39,10 +38,11 @@ IGNORE= Detected LibreSSL (RAND_METHOD structure unsupported)
post-patch:
@${REINPLACE_CMD} 's|%%PREFIX%%|${PREFIX}|g' \
- ${WRKSRC}/openssl.cnf.sample
+ ${WRKSRC}/dist/openssl.cnf.sample
post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/openssl.cnf.sample ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/dist/openssl.cnf.sample \
+ ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.post.mk>