aboutsummaryrefslogtreecommitdiff
path: root/security/openssl_tpm_engine/Makefile
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-09-13 17:37:25 +0000
committerJohn Marino <marino@FreeBSD.org>2016-09-13 17:37:25 +0000
commitf04235f80a022256dbf2669c998276c05859baac (patch)
tree8069cfd5374abc003c328aa96d294970217895ef /security/openssl_tpm_engine/Makefile
parent494f40a05fcc9ca0d39dbb97826291a96f16ab96 (diff)
Notes
Diffstat (limited to 'security/openssl_tpm_engine/Makefile')
-rw-r--r--security/openssl_tpm_engine/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/security/openssl_tpm_engine/Makefile b/security/openssl_tpm_engine/Makefile
index eebdf14afb64..68dec8555074 100644
--- a/security/openssl_tpm_engine/Makefile
+++ b/security/openssl_tpm_engine/Makefile
@@ -16,11 +16,11 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${LOCALBASE}/sbin/tcsd:security/trousers
LIB_DEPENDS= libtspi.so:security/trousers
-USES= autoreconf gmake libtool
+USES= autoreconf gmake libtool ssl
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-LDFLAGS+= -L${LOCALBASE}/lib -lcrypto
-CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${OPENSSLLIB} -lcrypto -L${LOCALBASE}/lib
+CFLAGS+= -I${OPENSSLINC} -I${LOCALBASE}/include
SUB_FILES= pkg-message
PLIST_FILES= bin/create_tpm_key \
lib/openssl/engines/libtpm.so \
@@ -31,6 +31,12 @@ PORTEXAMPLES= openssl.cnf.sample
OPTIONS_DEFINE= EXAMPLES
+.include <bsd.port.pre.mk>
+
+.if ${SSL_DEFAULT:Mlibressl*}
+IGNORE= Detected LibreSSL (RAND_METHOD structure unsupported)
+.endif
+
post-patch:
@${REINPLACE_CMD} 's|%%PREFIX%%|${PREFIX}|g' \
${WRKSRC}/openssl.cnf.sample
@@ -39,4 +45,4 @@ post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/openssl.cnf.sample ${STAGEDIR}${EXAMPLESDIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>