aboutsummaryrefslogtreecommitdiff
path: root/security/openvas-libraries
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2016-03-22 09:15:28 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2016-03-22 09:15:28 +0000
commita53cc62c5ce2dc9c1309af8ebf0a80b2da6158a0 (patch)
tree79e2f5d185cfda4eaeed27e44f311beb328608dd /security/openvas-libraries
parent9af7fc64559a103976a4bc3a98be584e3c7b2426 (diff)
Notes
Diffstat (limited to 'security/openvas-libraries')
-rw-r--r--security/openvas-libraries/files/patch-base-CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/security/openvas-libraries/files/patch-base-CMakeLists.txt b/security/openvas-libraries/files/patch-base-CMakeLists.txt
new file mode 100644
index 000000000000..6ad2c2ade684
--- /dev/null
+++ b/security/openvas-libraries/files/patch-base-CMakeLists.txt
@@ -0,0 +1,12 @@
+--- base/CMakeLists.txt.orig 2015-08-03 10:14:33 UTC
++++ base/CMakeLists.txt
+@@ -30,7 +30,8 @@ if (NOT MINGW)
+ # because they change the API (e.g. _FILE_OFFSET_BITS).
+ set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${HARDENING_FLAGS} -D_FILE_OFFSET_BITS=64 -Wall -fPIC")
+
+- pkg_check_modules (ZLIB REQUIRED zlib)
++ set (ZLIB_INCLUDE_DIRS "")
++ set (ZLIB_LDFLAGS "-lz")
+
+ pkg_check_modules (GIO REQUIRED gio-2.0)
+ endif (NOT MINGW)