aboutsummaryrefslogtreecommitdiff
path: root/security/openvas-plugins/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-08-17 22:48:23 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-08-17 22:48:23 +0000
commit0a6311719e4e16056ed4d7e496a3c542a0aa5a0f (patch)
tree09c107d5ad026c07f83e2af0d8eafc1acc7c94f5 /security/openvas-plugins/Makefile
parentf14ee492ceb241c441546a7e7142425dde9ba6af (diff)
Notes
Diffstat (limited to 'security/openvas-plugins/Makefile')
-rw-r--r--security/openvas-plugins/Makefile27
1 files changed, 12 insertions, 15 deletions
diff --git a/security/openvas-plugins/Makefile b/security/openvas-plugins/Makefile
index ca878cffd53d..8f9833e0f8d9 100644
--- a/security/openvas-plugins/Makefile
+++ b/security/openvas-plugins/Makefile
@@ -6,35 +6,32 @@
#
PORTNAME= openvas-plugins
-PORTVERSION= 1.0.0
-PORTREVISION= 3
+PORTVERSION= 1.0.7
CATEGORIES= security
-MASTER_SITES= http://wald.intevation.org/frs/download.php/412/
+MASTER_SITES= http://wald.intevation.org/frs/download.php/588/
MAINTAINER= cherry@trombik.org
COMMENT= Plugins for OpenVAS
BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet \
openvasd:${PORTSDIR}/security/openvas-server
-LIB_DEPENDS= openvas.1:${PORTSDIR}/security/openvas-libraries \
- openvasnasl.1:${PORTSDIR}/security/openvas-libnasl \
- gnutls.40:${PORTSDIR}/security/gnutls
+LIB_DEPENDS= openvas.2:${PORTSDIR}/security/openvas-libraries \
+ openvasnasl.2:${PORTSDIR}/security/openvas-libnasl \
+ gnutls.26:${PORTSDIR}/security/gnutls
RUN_DEPENDS= openvasd:${PORTSDIR}/security/openvas-server \
- ${LOCALBASE}/bin/gmd5sum:${PORTSDIR}/sysutils/coreutils \
- ${LOCALBASE}/bin/rsync:${PORTSDIR}/net/rsync
+ ${LOCALBASE}/bin/gmd5sum:${PORTSDIR}/sysutils/coreutils \
+ ${LOCALBASE}/bin/rsync:${PORTSDIR}/net/rsync
GNU_CONFIGURE= yes
LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include `${LIBNET_CONFIG} --cflags`" \
- LDFLAGS="-L${LOCALBASE}/lib"
-MAN1= openvas-build.1
+CPPFLAGS+= "`${LIBNET_CONFIG} --cflags`"
.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/security/openvas-libraries/Makefile.common"
+.include "${.CURDIR}/../openvas-libraries/Makefile.common"
-.if ${ARCH} != "i386"
-BROKEN= does not compile
-.endif
+#.if ${ARCH} != "i386"
+#BROKEN= does not compile
+#.endif
post-patch:
@${REINPLACE_CMD} -e 's|-lnet|`${LIBNET_CONFIG} --libs`|' \