aboutsummaryrefslogtreecommitdiff
path: root/security/openvas-plugins/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2008-06-04 13:17:20 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2008-06-04 13:17:20 +0000
commitcbc685fd829a3887832319bd0c93ce74843aeefa (patch)
tree21cb87cff8ffb1bfe175297317e63f73b2a487ed /security/openvas-plugins/Makefile
parent2b7aa4172c193fc05e8f2a632d262f689625041d (diff)
downloadports-cbc685fd829a3887832319bd0c93ce74843aeefa.tar.gz
ports-cbc685fd829a3887832319bd0c93ce74843aeefa.zip
Notes
Diffstat (limited to 'security/openvas-plugins/Makefile')
-rw-r--r--security/openvas-plugins/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/security/openvas-plugins/Makefile b/security/openvas-plugins/Makefile
new file mode 100644
index 000000000000..a29e82ce9033
--- /dev/null
+++ b/security/openvas-plugins/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: openvas-plugins
+# Date created: 2008-04-27
+# Whom: Tomoyuki Sakurai <cherry@trombik.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= openvas-plugins
+PORTVERSION= 1.0.0
+CATEGORIES= security
+MASTER_SITES= http://wald.intevation.org/frs/download.php/412/
+
+MAINTAINER= cherry@trombik.org
+COMMENT= Plugins for OpenVAS
+
+BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet \
+ openvasd:${PORTSDIR}/security/openvas-server
+LIB_DEPENDS= openvas.1:${PORTSDIR}/security/openvas-libraries \
+ openvasnasl.1:${PORTSDIR}/security/openvas-libnasl \
+ gnutls.26:${PORTSDIR}/security/gnutls
+RUN_DEPENDS= openvasd:${PORTSDIR}/security/openvas-server
+
+GNU_CONFIGURE= yes
+LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include `${LIBNET_CONFIG} --cflags`" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+MAN1= openvas-build.1
+
+.include "${.CURDIR}/../../security/openvas-server/Makefile.common"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lnet|`${LIBNET_CONFIG} --libs`|' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+ @${REINPLACE_CMD} -e 's|libnet-config|${LIBNET_CONFIG}|' \
+ ${WRKSRC}/plugins/3com_hub/Makefile
+
+.include <bsd.port.mk>