aboutsummaryrefslogtreecommitdiff
path: root/security/openvpn-auth-ldap
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2015-01-05 23:03:40 +0000
committerMatthias Andree <mandree@FreeBSD.org>2015-01-05 23:03:40 +0000
commit6f977b55ed0bed92525ded4d3801c26d8addbc2b (patch)
tree4c2f4c8c518202333f57f95596a12141ad166728 /security/openvpn-auth-ldap
parent53c049027fac37d75d812c7e65fa7efb21e9c09d (diff)
downloadports-6f977b55ed0bed92525ded4d3801c26d8addbc2b.tar.gz
ports-6f977b55ed0bed92525ded4d3801c26d8addbc2b.zip
Update to upstream SVN revision 1379 and refresh patches.
Needs real-world testing, so is still marked BROKEN. If there are positive test results from reporter or third parties, the BROKEN can be removed. PR: 190497
Notes
Notes: svn path=/head/; revision=376369
Diffstat (limited to 'security/openvpn-auth-ldap')
-rw-r--r--security/openvpn-auth-ldap/Makefile43
-rw-r--r--security/openvpn-auth-ldap/distinfo4
-rw-r--r--security/openvpn-auth-ldap/files/patch-src_TRLocalPacketFilter.m10
-rw-r--r--security/openvpn-auth-ldap/files/patch-src_TRString.h10
-rw-r--r--security/openvpn-auth-ldap/files/patch-tests_Makefile.in11
-rw-r--r--security/openvpn-auth-ldap/files/patch-tests__Makefile.in11
6 files changed, 63 insertions, 26 deletions
diff --git a/security/openvpn-auth-ldap/Makefile b/security/openvpn-auth-ldap/Makefile
index f21ed915533f..87b0744b562b 100644
--- a/security/openvpn-auth-ldap/Makefile
+++ b/security/openvpn-auth-ldap/Makefile
@@ -2,38 +2,40 @@
# $FreeBSD$
PORTNAME= openvpn-auth-ldap
-PORTVERSION= 2.0.3
-PORTREVISION= 9
+PORTVERSION= 2.0.4.0.s1379
CATEGORIES= security
-MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+#MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+MASTER_SITES= LOCAL/mandree
DISTNAME= auth-ldap-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= LDAP authentication plugin for OpenVPN
-# Older GCC used to provide +alloc and other methods on the Object
-# class, newer GCC/libobjc version no longer to that. The software
-# needs to learn to use the new Objective C world order:
-BROKEN= Needs to be ported to a new Object base-class with +alloc.
-
-USES= objc
+LICENSE= BSD3CLAUSE
BUILD_DEPENDS= re2c:${PORTSDIR}/devel/re2c \
- ${NONEXISTENT}:${PORTSDIR}/security/openvpn:extract
+ ${NONEXISTENT}:${PORTSDIR}/security/openvpn:extract \
+ libcheck>=0:${PORTSDIR}/devel/libcheck
+
+BROKEN= Untested SVN-based port, report success on https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=190497
+
+USES= objc tar:xz
GNU_CONFIGURE= yes
+USE_AUTOTOOLS= autoconf autoheader
USE_OPENLDAP= yes
OPENVPN_WRKSRC= `cd ${PORTSDIR}/security/openvpn; make -V WRKSRC`
CONFIGURE_ARGS+= --with-openldap=${LOCALBASE} \
--with-openvpn=${OPENVPN_WRKSRC}/include \
--with-objc-runtime=GNU
# this issue would cause run-time trouble, so turn it into an error:
-OBJCFLAGS+= -Werror=objc-method-access
+#OBJCFLAGS+= -Werror=objc-method-access
PORTDOCS= README
PORTEXAMPLES= auth-ldap.conf
PLIST_FILES= lib/openvpn-auth-ldap.so
-OBJCFLAGS+= -L/usr/local/lib
+OBJCFLAGS+= -L${LOCALBASE}/lib -I${LOCALBASE}/include -fPIC
+CFLAGS+= -fPIC
OPTIONS_DEFINE= DOCS EXAMPLES
.include <bsd.port.options.mk>
@@ -41,7 +43,7 @@ OPTIONS_DEFINE= DOCS EXAMPLES
CONFIGURE_ENV+= OBJC="${CC}"
post-patch:
- ${REINPLACE_CMD} 's|-export-dynamic|-Wl,-export-dynamic|' ${WRKSRC}/configure
+ ${REINPLACE_CMD} 's|-export-dynamic|-Wl,-export-dynamic|' ${WRKSRC}/configure.ac
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/openvpn-auth-ldap.so
@@ -55,5 +57,20 @@ post-install:
.endif
.include <bsd.port.pre.mk>
+
CC+= ${DEBUG_FLAGS}
+
+# this is a local target to build a tarball from SVN
+# and another target to upload it
+build-tarball: ${DISTFILES}
+${DISTFILES}:
+ ${RM} -rf ${WRKSRC}
+ svn export -r${PORTVERSION:E:C/^s//} \
+ http://openvpn-auth-ldap.googlecode.com/svn/trunk/ ${WRKSRC}
+ tar -C ${WRKSRC}/.. -cvf - ${WRKSRC:T} | ${XZ_CMD} -vvc >${DISTFILES} || \
+ { ${RM} -f ${DISTFILES} ; exit 1 ; }
+
+upload-tarball: build-tarball
+ scp ${DISTFILES} freefall.freebsd.org:public_distfiles/
+
.include <bsd.port.post.mk>
diff --git a/security/openvpn-auth-ldap/distinfo b/security/openvpn-auth-ldap/distinfo
index d65876e2dc1b..9b234cf37237 100644
--- a/security/openvpn-auth-ldap/distinfo
+++ b/security/openvpn-auth-ldap/distinfo
@@ -1,2 +1,2 @@
-SHA256 (auth-ldap-2.0.3.tar.gz) = 2b258610b0f3fe9ce097b0e88b4c78e402e5f3f814b7d327392ba72574d1b63a
-SIZE (auth-ldap-2.0.3.tar.gz) = 261832
+SHA256 (auth-ldap-2.0.4.0.s1379.tar.xz) = 8d35eb540482d8d2bf36d0d310241b69633691f28477867ecee28c76912476cc
+SIZE (auth-ldap-2.0.4.0.s1379.tar.xz) = 163724
diff --git a/security/openvpn-auth-ldap/files/patch-src_TRLocalPacketFilter.m b/security/openvpn-auth-ldap/files/patch-src_TRLocalPacketFilter.m
new file mode 100644
index 000000000000..890c765d6180
--- /dev/null
+++ b/security/openvpn-auth-ldap/files/patch-src_TRLocalPacketFilter.m
@@ -0,0 +1,10 @@
+--- src/TRLocalPacketFilter.m.orig 2012-03-03 19:17:45 UTC
++++ src/TRLocalPacketFilter.m
+@@ -43,6 +43,7 @@
+ #import <errno.h>
+ #import <assert.h>
+
++#import "TRLog.h"
+
+ /* Private Methods */
+
diff --git a/security/openvpn-auth-ldap/files/patch-src_TRString.h b/security/openvpn-auth-ldap/files/patch-src_TRString.h
new file mode 100644
index 000000000000..4155792aa940
--- /dev/null
+++ b/security/openvpn-auth-ldap/files/patch-src_TRString.h
@@ -0,0 +1,10 @@
+--- src/TRString.h.orig 2012-08-15 13:55:46 UTC
++++ src/TRString.h
+@@ -34,6 +34,7 @@
+ #import <config.h>
+ #endif
+
++#import <stdarg.h>
+ #import <stdlib.h>
+
+ #import "TRObject.h"
diff --git a/security/openvpn-auth-ldap/files/patch-tests_Makefile.in b/security/openvpn-auth-ldap/files/patch-tests_Makefile.in
new file mode 100644
index 000000000000..9c6ef89a8b67
--- /dev/null
+++ b/security/openvpn-auth-ldap/files/patch-tests_Makefile.in
@@ -0,0 +1,11 @@
+--- tests/Makefile.in.orig 2012-03-04 04:55:05 UTC
++++ tests/Makefile.in
+@@ -35,7 +35,7 @@ TEST_OBJS= tests.o \
+ CFLAGS+= -DTEST_DATA=\"${srcdir}/data\"
+ OBJCFLAGS+= -DTEST_DATA=\"${srcdir}/data\"
+
+-LIBS+= -L${top_builddir}/src -lauth-ldap \
++LIBS+= -L${top_builddir}/src -lauth-ldap -lcheck \
+ $(OBJC_LIBS) $(LDAP_LIBS)
+
+ LDFLAGS+= $(LIBS)
diff --git a/security/openvpn-auth-ldap/files/patch-tests__Makefile.in b/security/openvpn-auth-ldap/files/patch-tests__Makefile.in
deleted file mode 100644
index 4c21d67eddf9..000000000000
--- a/security/openvpn-auth-ldap/files/patch-tests__Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./tests/Makefile.in.orig 2006-08-01 05:51:52.000000000 +0200
-+++ ./tests/Makefile.in 2014-08-03 09:26:42.000000000 +0200
-@@ -26,7 +26,7 @@
- CFLAGS+= @CHECK_CFLAGS@ -DTEST_DATA=\"${srcdir}/data\"
- OBJCFLAGS+= @CHECK_CFLAGS@ -DTEST_DATA=\"${srcdir}/data\"
- LIBS+= -lauth-ldap-testing $(OBJC_LIBS) $(LDAP_LIBS) @CHECK_LIBS@
--LDFLAGS+= -L${top_builddir}src $(LIBS)
-+LDFLAGS+= -L${top_builddir}/src $(LIBS)
-
- # Recompile the tests every time
- all: tests