aboutsummaryrefslogtreecommitdiff
path: root/security/openvpn-auth-ldap
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2014-01-02 00:15:02 +0000
committerMatthias Andree <mandree@FreeBSD.org>2014-01-02 00:15:02 +0000
commit13cb94b98a4125c9668f4d0c12becccbfd3d6907 (patch)
tree9ae8d0974b8747c9d55cbd02ceabf1483648d04c /security/openvpn-auth-ldap
parent41ff670cc79abe940c54db04149a7e7245737506 (diff)
downloadports-13cb94b98a4125c9668f4d0c12becccbfd3d6907.tar.gz
ports-13cb94b98a4125c9668f4d0c12becccbfd3d6907.zip
Notes
Diffstat (limited to 'security/openvpn-auth-ldap')
-rw-r--r--security/openvpn-auth-ldap/Makefile28
-rw-r--r--security/openvpn-auth-ldap/files/patch-tests-Makefile.in11
2 files changed, 27 insertions, 12 deletions
diff --git a/security/openvpn-auth-ldap/Makefile b/security/openvpn-auth-ldap/Makefile
index d8f0858f5182..99d28f0e92b9 100644
--- a/security/openvpn-auth-ldap/Makefile
+++ b/security/openvpn-auth-ldap/Makefile
@@ -3,7 +3,7 @@
PORTNAME= openvpn-auth-ldap
PORTVERSION= 2.0.3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
DISTNAME= auth-ldap-${PORTVERSION}
@@ -18,31 +18,35 @@ GNU_CONFIGURE= yes
USE_OPENLDAP= yes
OPENVPN_WRKSRC= `cd ${PORTSDIR}/security/openvpn; make -V WRKSRC`
CONFIGURE_ARGS+= --with-openldap=${LOCALBASE} \
- --with-openvpn=${OPENVPN_WRKSRC}
+ --with-openvpn=${OPENVPN_WRKSRC}/include \
+ --with-objc-runtime=GNU
PORTDOCS= README
PORTEXAMPLES= auth-ldap.conf
PLIST_FILES= lib/openvpn-auth-ldap.so
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
+OPTIONS_DEFINE= DOCS EXAMPLES
+.include <bsd.port.options.mk>
.if (${OSVERSION} >= 900000 && ${OSVERSION} < 900012) || ${OSVERSION} < 800505
BUILD_DEPENDS+= ${LOCALBASE}/bin/xz:${PORTSDIR}/archivers/xz
.endif
.if ${OSVERSION} >= 900000
-BROKEN= does not configure on FreeBSD 9.X
+# Use gcc from ports because Objective C support no longer included in base
+USE_GCC= yes
+CONFIGURE_ENV+= OBJC="${CC}"
.endif
post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/openvpn-auth-ldap.so
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
.endif
-.if !defined(NOPORTEXAMPLES)
- ${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/auth-ldap.conf ${EXAMPLESDIR}
+.if ${PORT_OPTIONS:MEXAMPLES}
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/auth-ldap.conf ${STAGEDIR}${EXAMPLESDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/openvpn-auth-ldap/files/patch-tests-Makefile.in b/security/openvpn-auth-ldap/files/patch-tests-Makefile.in
new file mode 100644
index 000000000000..9405979d6338
--- /dev/null
+++ b/security/openvpn-auth-ldap/files/patch-tests-Makefile.in
@@ -0,0 +1,11 @@
+--- tests/Makefile.in.orig 2006-08-01 05:51:52.000000000 +0200
++++ tests/Makefile.in 2013-06-09 06:33:07.000000000 +0200
+@@ -26,7 +26,7 @@
+ CFLAGS+= @CHECK_CFLAGS@ -DTEST_DATA=\"${srcdir}/data\"
+ OBJCFLAGS+= @CHECK_CFLAGS@ -DTEST_DATA=\"${srcdir}/data\"
+ LIBS+= -lauth-ldap-testing $(OBJC_LIBS) $(LDAP_LIBS) @CHECK_LIBS@
+-LDFLAGS+= -L${top_builddir}src $(LIBS)
++LDFLAGS+= -L${top_builddir}/src $(LIBS)
+
+ # Recompile the tests every time
+ all: tests