aboutsummaryrefslogtreecommitdiff
path: root/security/openvpn-beta
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2011-07-25 20:03:44 +0000
committerMatthias Andree <mandree@FreeBSD.org>2011-07-25 20:03:44 +0000
commit69f20e878e83d3c8923edbfe04a76f84c124e6a1 (patch)
tree5a65bcb6b14be885cbbc8da48149f5a8a6c010b9 /security/openvpn-beta
parent74fb18cff076748626d0da794912137a621019dd (diff)
Notes
Diffstat (limited to 'security/openvpn-beta')
-rw-r--r--security/openvpn-beta/Makefile17
1 files changed, 7 insertions, 10 deletions
diff --git a/security/openvpn-beta/Makefile b/security/openvpn-beta/Makefile
index 7a01dc59bbd5..61f48be55692 100644
--- a/security/openvpn-beta/Makefile
+++ b/security/openvpn-beta/Makefile
@@ -13,6 +13,11 @@ PKGNAMESUFFIX= -beta
MAINTAINER= ecrist@secure-computing.net
COMMENT= Secure IP/Ethernet tunnel daemon
+# ecrist will update the -beta port as soon as there are formal
+# upstream test releases derived from openvpn-devel; in the meanwhile,
+# move users to -devel.
+DEPRECATED= use openvpn-devel instead for now, there are currently no formal -betas.
+
CONFLICTS= openvpn-devel-[0-9]* openvpn-2.0*
USE_XZ= yes
@@ -31,6 +36,8 @@ OPTIONS= PW_SAVE "Interactive passwords may be read from a file" off \
USE_RC_SUBR= openvpn.sh
USE_LDCONFIG= ${PREFIX}/lib
+LIB_DEPENDS+= lzo2.2:${PORTSDIR}/archivers/lzo2
+
SUB_FILES= pkg-message pkg-req
SUB_LIST+= OSVERSION=${OSVERSION}
@@ -52,16 +59,6 @@ pre-fetch:
@${ECHO} ""
.endif
-# NOTE: there is no way to explicitly specify the LZO version to OpenVPN,
-# if LZO2 and LZO1 are installed, OpenVPN will pick LZO2.
-# So depend on LZO1 only if it's already there and LZO2 isn't.
-# PACKAGE_BUILDING will also force LZO2.
-.if exists(${LOCALBASE}/lib/liblzo2.so.2) || !exists(${LOCALBASE}/lib/liblzo.so.1) || defined(PACKAGE_BUILDING)
-LIB_DEPENDS+= lzo2.2:${PORTSDIR}/archivers/lzo2
-.else
-LIB_DEPENDS+= lzo.1:${PORTSDIR}/archivers/lzo
-.endif
-
.if defined(WITH_PW_SAVE)
CONFIGURE_ARGS+= --enable-password-save
.endif