aboutsummaryrefslogtreecommitdiff
path: root/security/openvpn-devel/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-07-18 10:48:06 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-07-18 10:48:06 +0000
commit65f1acd8f6f7fd70498f97b71a14a583e617bbba (patch)
tree43008844129b071fad29ccfb02b828a8b22ac22c /security/openvpn-devel/Makefile
parent24e3d7b9a11f68b2f0d24949699f064cb1ce1214 (diff)
downloadports-65f1acd8f6f7fd70498f97b71a14a583e617bbba.tar.gz
ports-65f1acd8f6f7fd70498f97b71a14a583e617bbba.zip
Notes
Diffstat (limited to 'security/openvpn-devel/Makefile')
-rw-r--r--security/openvpn-devel/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/security/openvpn-devel/Makefile b/security/openvpn-devel/Makefile
index 6e5f02e3b05c..1d318a197693 100644
--- a/security/openvpn-devel/Makefile
+++ b/security/openvpn-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= openvpn
DISTVERSION= 2.1_rc8
+PORTREVISION= 1
CATEGORIES= security net
MASTER_SITES= https://secure.openvpn.net/beta/
PKGNAMESUFFIX= -devel
@@ -77,10 +78,14 @@ post-install:
PORTS README
${INSTALL_DATA} ${WRKSRC}/${docs} ${DOCSDIR}/
.endfor
- ( cd ${WRKSRC} \
- && ${FIND} easy-rsa sample-config-files sample-scripts -depth \
- | ${GREP} -v easy-rsa/Windows \
- | ${CPIO} -pdmu ${DOCSDIR} )
+.for dir in easy-rsa easy-rsa/1.0 easy-rsa/2.0 sample-config-files
+ ${MKDIR} ${DOCSDIR}/${dir}
+ ${FIND} ${WRKSRC}/${dir}/ -maxdepth 1 -type f -exec ${INSTALL_DATA} \{\} ${DOCSDIR}/${dir} \;
+.endfor
+.for dir in sample-scripts
+ ${MKDIR} ${DOCSDIR}/${dir}
+ ${FIND} ${WRKSRC}/${dir}/ -maxdepth 1 -type f -exec ${INSTALL_SCRIPT} \{\} ${DOCSDIR}/${dir} \;
+.endfor
.else
-@${RMDIR} ${DOCSDIR}
.endif