aboutsummaryrefslogtreecommitdiff
path: root/security/openvpn/Makefile
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2019-07-13 08:31:14 +0000
committerMatthias Andree <mandree@FreeBSD.org>2019-07-13 08:31:14 +0000
commitaa5509fff00cf0a5f28755bd036855a403e3399e (patch)
treead26da95aa2f485769edd326adfdf343890ba18e /security/openvpn/Makefile
parentdd4250b2b54aa00bbb56ecca606751308ccccf98 (diff)
downloadports-aa5509fff00cf0a5f28755bd036855a403e3399e.tar.gz
ports-aa5509fff00cf0a5f28755bd036855a403e3399e.zip
Notes
Diffstat (limited to 'security/openvpn/Makefile')
-rw-r--r--security/openvpn/Makefile14
1 files changed, 2 insertions, 12 deletions
diff --git a/security/openvpn/Makefile b/security/openvpn/Makefile
index 044384066bac..0601cf6002e7 100644
--- a/security/openvpn/Makefile
+++ b/security/openvpn/Makefile
@@ -41,7 +41,7 @@ OPTIONS_SINGLE= SSL
OPTIONS_SINGLE_SSL= OPENSSL MBEDTLS
PKCS11_DESC= Use security/pkcs11-helper
EASYRSA_DESC= Install security/easy-rsa RSA helper package
-MBEDTLS_DESC= SSL/TLS via mbedTLS
+MBEDTLS_DESC= SSL/TLS via mbedTLS (lacks TLS v1.3)
TUNNELBLICK_DESC= Tunnelblick XOR scramble patch (READ HELP!)
X509ALTUSERNAME_DESC= Enable --x509-username-field (OpenSSL only)
SMALL_DESC= Build a smaller executable with fewer features
@@ -62,6 +62,7 @@ X509ALTUSERNAME_PREVENTS_MSG= OpenVPN ${DISTVERSION} cannot use --x509-username-
OPENSSL_USES= ssl
OPENSSL_CONFIGURE_ON= --with-crypto-library=openssl
+IGNORE_SSL= libressl libressl-devel
LZ4_CONFIGURE_OFF= --disable-lz4
@@ -115,17 +116,6 @@ _tlslibs=libmbedtls libmbedx509 libmbedcrypto
_tlslibs=libssl libcrypto
.endif
-.if ${SSL_DEFAULT:Mlibressl*} && empty(PORT_OPTIONS:MMBEDTLS)
-pre-everything::
- @${ECHO_CMD} "WARNING: OpenVPN does not officially support LibreSSL."
- @${ECHO_CMD} "If things break, rebuild with OpenSSL or mbedTLS."
- @${ECHO_CMD} "You may wish to change your default SSL library"
- @${ECHO_CMD} "and press Ctrl+C within the next 10 seconds to abort."
-. if !(defined(PACKAGE_BUILDING) || defined(BATCH))
- @sleep 10
-. endif
-.endif
-
# sanity check that we don't inherit incompatible SSL libs through,
# for instance, pkcs11-helper:
post-build: