aboutsummaryrefslogtreecommitdiff
path: root/security/openvpn20
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2013-06-01 16:47:41 +0000
committerMatthias Andree <mandree@FreeBSD.org>2013-06-01 16:47:41 +0000
commit21651912091814078b4e7c300339d7458037fc88 (patch)
tree237b27c6e1c3492fbc29802aed7d2b18f483f845 /security/openvpn20
parentc5b0418a40d13460467414b647bf5778ca3c0e5e (diff)
downloadports-21651912091814078b4e7c300339d7458037fc88.tar.gz
ports-21651912091814078b4e7c300339d7458037fc88.zip
Notes
Diffstat (limited to 'security/openvpn20')
-rw-r--r--security/openvpn20/Makefile2
-rw-r--r--security/openvpn20/files/patch-CVE-2013-206174
2 files changed, 75 insertions, 1 deletions
diff --git a/security/openvpn20/Makefile b/security/openvpn20/Makefile
index 6d3b0cdcb587..4ee0e963858a 100644
--- a/security/openvpn20/Makefile
+++ b/security/openvpn20/Makefile
@@ -3,7 +3,7 @@
PORTNAME= openvpn
PORTVERSION= 2.0.9
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= security net
# MASTER_SITES points to hosts in distinct data centers,
# so just one MASTER_SITES entry should be OK.
diff --git a/security/openvpn20/files/patch-CVE-2013-2061 b/security/openvpn20/files/patch-CVE-2013-2061
new file mode 100644
index 000000000000..fc622b37a131
--- /dev/null
+++ b/security/openvpn20/files/patch-CVE-2013-2061
@@ -0,0 +1,74 @@
+commit 11d21349a4e7e38a025849479b36ace7c2eec2ee
+Author: Steffan Karger <steffan.karger@fox-it.com>
+Date: Tue Mar 19 13:01:50 2013 +0100
+
+ Use constant time memcmp when comparing HMACs in openvpn_decrypt.
+
+ Signed-off-by: Steffan Karger <steffan.karger@fox-it.com>
+ Acked-by: Gert Doering <gert@greenie.muc.de>
+ Signed-off-by: Gert Doering <gert@greenie.muc.de>
+
+diff --git a/src/openvpn/buffer.h b/src/openvpn/buffer.h
+index 7cae733..93efb09 100644
+--- ./buffer.h~
++++ ./buffer.h
+@@ -668,6 +668,10 @@ buf_read_u32 (struct buffer *buf, bool *good)
+ }
+ }
+
++/**
++ * Compare src buffer contents with match.
++ * *NOT* constant time. Do not use when comparing HMACs.
++ */
+ static inline bool
+ buf_string_match (const struct buffer *src, const void *match, int size)
+ {
+@@ -676,6 +680,10 @@ buf_string_match (const struct buffer *src, const void *match, int size)
+ return memcmp (BPTR (src), match, size) == 0;
+ }
+
++/**
++ * Compare first size bytes of src buffer contents with match.
++ * *NOT* constant time. Do not use when comparing HMACs.
++ */
+ static inline bool
+ buf_string_match_head (const struct buffer *src, const void *match, int size)
+ {
+diff --git a/src/openvpn/crypto.c b/src/openvpn/crypto.c
+index 405c0aa..d9adf5b 100644
+--- ./crypto.c~
++++ ./crypto.c
+@@ -65,6 +65,24 @@
+ #define CRYPT_ERROR(format) \
+ do { msg (D_CRYPT_ERRORS, "%s: " format, error_prefix); goto error_exit; } while (false)
+
++/**
++ * As memcmp(), but constant-time.
++ * Returns 0 when data is equal, non-zero otherwise.
++ */
++static int
++memcmp_constant_time (const void *a, const void *b, size_t size) {
++ const uint8_t * a1 = a;
++ const uint8_t * b1 = b;
++ int ret = 0;
++ size_t i;
++
++ for (i = 0; i < size; i++) {
++ ret |= *a1++ ^ *b1++;
++ }
++
++ return ret;
++}
++
+ void
+ openvpn_encrypt (struct buffer *buf, struct buffer work,
+ const struct crypto_options *opt,
+@@ -244,7 +262,7 @@ openvpn_decrypt (struct buffer *buf, struct buffer work,
+ hmac_ctx_final (ctx->hmac, local_hmac);
+
+ /* Compare locally computed HMAC with packet HMAC */
+- if (memcmp (local_hmac, BPTR (buf), hmac_len))
++ if (memcmp_constant_time (local_hmac, BPTR (buf), hmac_len))
+ CRYPT_ERROR ("packet HMAC authentication failed");
+
+ ASSERT (buf_advance (buf, hmac_len));