aboutsummaryrefslogtreecommitdiff
path: root/security/openvpn
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2013-01-13 21:35:06 +0000
committerMatthias Andree <mandree@FreeBSD.org>2013-01-13 21:35:06 +0000
commitf094e1198da3179fc054f5ebf854b69875d38082 (patch)
tree8102ec2337c70614e5f4d86111556a71c12bb94d /security/openvpn
parent5d2a35702ab4d545dfcda627f86097874166be95 (diff)
downloadports-f094e1198da3179fc054f5ebf854b69875d38082.tar.gz
ports-f094e1198da3179fc054f5ebf854b69875d38082.zip
Notes
Diffstat (limited to 'security/openvpn')
-rw-r--r--security/openvpn/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/security/openvpn/Makefile b/security/openvpn/Makefile
index dfcf0d0f2fff..76bb906fbfe4 100644
--- a/security/openvpn/Makefile
+++ b/security/openvpn/Makefile
@@ -3,11 +3,10 @@
PORTNAME= openvpn
DISTVERSION= 2.3.0
+PORTREVISION= 1
CATEGORIES= security net
-# MASTER_SITES points to hosts in distinct data centers,
-# so just one MASTER_SITES entry should be OK.
MASTER_SITES= http://swupdate.openvpn.net/community/releases/ \
- ${MASTER_SITE_LOCAL:S,$,mandree/,}
+ http://build.openvpn.net/downloads/releases/
MAINTAINER= mandree@FreeBSD.org
COMMENT= Secure IP/Ethernet tunnel daemon
@@ -24,9 +23,11 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
# PolarSSL missing: OpenVPN does not currently compile with PolarSSL 1.2.0+
-OPTIONS_DEFINE= PW_SAVE PKCS11
+OPTIONS_DEFINE= PW_SAVE PKCS11 EASYRSA
+OPTIONS_DEFAULT= EASYRSA
PW_SAVE_DESC= Interactive passwords may be read from a file
PKCS11_DESC= Use security/pkcs11-helper
+EASYRSA_DESC= Install security/easy-rsa RSA helper package
.include <bsd.port.options.mk>
@@ -36,6 +37,10 @@ INSTALL_TARGET= install
INSTALL_TARGET= install-exec install-man
.endif
+.if ${PORT_OPTIONS:MEASYRSA}
+RUN_DEPENDS+= easy-rsa>=0:${PORTSDIR}/security/easy-rsa
+.endif
+
INSTALL_TARGET+= mandir=${MANPREFIX}/man
MAN8= openvpn.8